Application Scrobbling not working propper

I’m using the same apps on different Computers (e.g. Windows Explorer, Browser, Thunderbird, Miranda…)

They are pulsed from different Computers, but stats only shown one computer :frowning:

Anyone? Did i miss an Option?

The apps are pulsed but the Computers did not shown in app stats and the Counter within myapps is always 1 :frowning:

Would you happen to be running Windows 8? My apps haven’t been uploaded when pulsing from either of my Windows 8 machines. Windows 7 pulses just fine.

I’m sorry, the English got a little foggy so I didn’t get what you were saying at first, but you’re talking about the website.

For some reason your applications are -all- linked to the computer MegMac. There is one reason for that to happen: on computer DC89, did you login with computer MegMac first and then switched? Or carried the whatpulse.db file around any?

In any case: try the ‘Re-upload applications’ button in the advanced settings of DC89.

This could be possible. First i used WP portable on all Computers and after a while i switched back to normal usage.

I’ll try this…

Nope, sorry. Win8 is the only one, which works almost fine. (some apps missing, see

I haven’t seen any application uploads other than the ones from MegMac…you’ll need to re-upload first before it’ll show correctly.

If you share the database amongst computers, the application IDs get mixed up and you get this.

Didn’t know, if I wrote this already in personal message:

I’ve checked the reupload applications on P310. This is fresh blank installation of whatpulse. Still no applications shown in pulses nor a second pc is shown in applications :frowning:

Still not tested on DC89.

What about this Problem? can you confirm that? will there be an updated Routine on the next Version?

THX a lot

Sorry, but it can’t be a clean installation as you say, simply because there are still application IDs in your local database that are linked to another computer…If you really started clean and logged in using the right computer, it will either send no applications (if it can’t collect info) or link the applications to the computer you’ve logged in with…

For debug purposes, the website currently writes the full application upload away in a file, including the computer name…and this is what it says for your account:

[martijn@web5 237942]# grep -i ‘computer:’ * | grep -v MegMac
[martijn@web5 237942]#

This is a command for ‘find a computer with application uploads that’s not from MegMac’ - and it did not find any uploads.

While there are plenty of app uploads from MegMac:

[martijn@web5 237942]# grep -i ‘computer:’ * | grep MegMac | wc -l

(This is since July).

About the other thread; I closed it because you said “all is fine” - about the apps, so I’m not sure what you want to confirm.

The only thing/routine adjusted in the upcoming version will be the detection of a computer mismatch on uploads applications, so that it’ll clear it automatically, instead of doing it manually via the ‘re-upload apps’.

If you are absolutely sure you have done the ‘re-upload apps’ on the right computer (so not MegMac), seen the upload notification bar, please send me your whatpulse.db file so I can have a look.

Where to send this?

To clarify my open questions/problems:

  1. On MegMac (and possible on all other machines), apps which do not have a description compiled in, are not uploaded. The local detection on WP Client seems to work correctly, but they aren’t submitted or displayed.
    (See example screenshots)

  2. Apps seems not submitted (neither on P310 nor on Meg-VM). They are not assigned to MegMac, they are missing completely. Tested “re-upload applications” on both machines.
    – How Long will it takes until apps are computed? —

  3. IE (keys, mouse clicks) on DC89 (WinXP, 32 bit) are not detected proper.

4. The problem with DC89 (apps are assigned to MegMac) i will check on Wednesday.

– How Long will it takes until apps are computed? —

To Point 1 and screen shots. As you recommend, i’ve looked into the wp.db on MacMeg, 200 of 300 Apps did not have an online id, version and send_online is set to 0 (false?)

Also have take a look at pending_application_stats. The missing apps are listen there, so I think they where submitted (do not sniff my network traffic) but not parsed (cause of the missing id?)

So i take a look into the wp db of P310. The application table is completely empty! All others like pending_application_stats, application_active_hour, application_bandwidth are filled as usual.

Also it looks like in settings on P310, the following entries are missing (+2 others, it has 64 rows where settings on MegMac has 70 rows)

Just dropbox/rapidshare/googledocs or even email it.

All applications that ‘matter’ have their info filled out, and it’s correct that the client ignores applications that do not have the info.

If your application table is empty, it means you have the uptime per application setting disabled. In current versions this table is linked to that setting, dating from where that setting was the only one using it. (has been changed in 2.2.2)

pending_application_stats is purely filled with a program path and it’s stats. Matching it to an application ID and sorting data for pulsing is done later on. If an app hasn’t been uploaded (so it doesn’t have an ID), the pending_application_stats entry is ignored.

You can ignore the excess/minor settings; those are leftovers from older versions.

The client checks every 15 minutes for applications it needs to upload and does 50 apps at once. So it depends on how many applications you have on how long it’ll take. That’s why the re-upload message is “it could take an hour or so”

The reason for that is that there’s a limit to what amount of text it can send at once…and there can be a lot of applications on ones computer, but right now it sends everything. I’m debating whether that should be changed to active apps (found in pending_application_stats) only, so I might change it in 2.2.2.

G+ … interesting, immediately after sharing, google told me, that 3 people accessing the file !?

Are this meant, that these apps will not get an online id?
Even Firefox did not get one.
Will this changed in further releases?

No, i didn’t. Possible you can check this on the shared db?

I do not think that i’ve ever get 50 running apps/processes. at least not on P310. Could that the reason why there is still no appusage pulsed from that client?

Your solution on DC89 worked. So less one problem.

Correct, they will not even be uploaded. The website needs some info on an application for it to show something, otherwise all it has is the .exe name.

[quote=“Megachip, post:12, topic:12641”]
I do not think that i’ve ever get 50 running apps/processes. at least not on P310. Could that the reason why there is still no appusage pulsed from that client?[/quote]

It doesn’t upload on ‘exactly’ 50 applications, it’s just limited to 50 apps per upload sequence, to lessen the load. If you have 1 or 5 new applications, it’ll send it in that 15 minute interval.

Why not, Icon + Filename (and Version if there is one) will not be enough to show?
Hope apps will identified on hashsum?

Hmm, so i’ll ask wireshark, if i found some time. Possible it could tell me, why there is no application info uploaded on These maschines.

Hah, that would mean we would have to have a database of -every- application with it’s checksum available…good one. :wink:

If an application does not have it’s info filled out, it’s not interesting enough to capture.

Why? Build the checksum of an app, if not in db, enter it (together with appinfo, icon and so on). if in db, use it.
It worked on wakoopa, why it should not working on whatpulse?

How do you identify a application atm?

Ok, i’ve got the Point. But not sharing this opinion with you.

But i think this should discussed in a separate thread.

btw, did you found anything useful in the db regarding the problem on p310/meg-VM?

Tested the “Re-Upload Application” Function again and take a look at package sniffer… nothing… not even a Connection-Initiation. Should i wait 15 min?

[quote=“Megachip, post:17, topic:12641”]
Why? Build the checksum of an app, if not in db, enter it (together with appinfo, icon and so on). if in db, use it.
It worked on wakoopa, why it should not working on whatpulse?[/quote]

You’d need the application information to identify the first application of it’s sort…and considering that application info is empty in the applications you’re talking about, you have the same chicken and egg problem.

Through the application info…which the applications you’re talking about do not have, so they cannot be identified.

[quote=“Megachip, post:17, topic:12641”]
Ok, i’ve got the Point. But not sharing this opinion with you. But i think this should discussed in a separate thread.[/quote]

Not sure what you mean, but if you feel you need to split something up, go ahead.

[quote=“Megachip, post:17, topic:12641”]
btw, did you found anything useful in the db regarding the problem on p310/meg-VM?[/quote]

Yep, that the application uptime was not enabled, as I mentioned a few posts back. The table ‘applications’ is empty, so it cannot upload any info, because it doesn’t have any info.

As also mentioned before, this will be different in 2.2.2, where applications will always be gathered, so there’s no option you can mistakenly disable and mess up the application info globally.

[quote=“smitmartijn, post:18, topic:12641”]

Again, i dount think so. How i would bild it:
On Client:
Create a unique hash of the app (see below)
submit stats with this hash
If hash is found on serverdb, all fine, if not, Response to Client to aquire informations (Filename, Version, Description, Icon and so on…)

The following parts could used to build a unique hash:

  • Filename
  • Filesize
  • Filedate
  • Filedescription (Name, Version, Language…)
  • Bytehash (could take a bit on big executables)
  • Icon

Most of These informations are also exist on files where filedescription missing. Also filedescription is not a unique value :confused:

[quote=“smitmartijn, post:18, topic:12641”]

As already mentioned (and double checked) These Option is marked on ui. But possible 2.2.2 will fix this? Did you have any release date? Or public beta?

Today, i take a look into the db on DC89 … Looks most of the apps missing an online id. Will they gather it later?
Some apps like winrar and Windows Explorer get the online_app_id “1”, what did this mean?

Your idea is proper, but you’re missing a critical point. There -HAS- to be an initial upload -WITH- the application information before you can show the information on the website. Application information doesn’t magically appear or disappear from an .exe, it is filled out by the developer of that application. All the checksums of an .exe of -1- version are the same. Same application, different version, the checksum will be different.

So the application information for a certain .exe either exists or it doesn’t, there will not be a situation where someone has version 1 of app.exe installed that -DOES- have the information available, and where someone who also has version 1 of app.exe that -DOESN’T- have the application information.

So the idea is great, but it simply wouldn’t work.