WhatPulse not registering keystrokes unless in a fullscreen application.

EDIT: Turned out keyscrambler was at fault. Not sure why it started all of a sudden though…

This problem started yesterday on 5/2/2014. Example: http://i.imgur.com/5tbnf0L.png

I’ve uninstalled WhatPulse, used a registry cleaner, rebooted, then installed again to try to fix it. The keys seemed to have tracked correctly when I was in a game (Dota 2).

The problem persists regardless of whether or not I am running as admin.

Keys such as Caps Lock, Shift, etc register fine but all others do not.

  1. Running latest version 2.4

  2. OS: Windows 8.1 64-bit Pro w/ Media Center.

  3. Yes, running as admin/not running as admin, same problem. The settings also have run as admin ticked.

  4. No error msgs

  5. I’ve been running malwarebytes for a while and it worked 100% fine together so it shouldn’t be an issue. I tried closing it and it didn’t fix anything.

  6. Screenshots:

I can fully understand why Keyscrambler would block WhatPulse, as it receives a copy of the keys, but instead of logging, it counts it. But there’s no way keyscrambler can know that last bit, as it probably looks for what Windows API calls are being used.