WhatPulse client crashing on load; app.log indicates the issue is GeoIP.dat

3.6 on Windows 11 21H2 x64, logged in as a local admin, and force-launching as admin in the shortcut since app.log indicated some instances weren’t starting as administrator so I briefly thought that might’ve been the culprit. Anyway the problems started a few hours ago with one of those “your client has restarted multiple times” errors, tried reinstalling with no luck, did a clean reinstall (after I discovered a duplicate Whatpulse installation directory (named “Whatpulse2”) had been created instead of the reinstall overwriting the previous client – why???) and now it just crashes out at start. Reading through app.log indicates the last thing it does before crashing out is it attempts to open the GeoIP database and fails. Incidentally the GeoIP.dat that I keep getting is a blank file 0kb in size. So if I delete it, the client stays active for a few seconds longer as it attempts to redownload the database before crashing out as, again, the GeoIP.dat file is blank.

Incidentally, running the latest beta works, but the app.log there instead indicates that the client can’t download Updates.xml from the server as it gets a 403 Forbidden error.

You can download a new GeoIP.dat file from here :

I downloaded the GeoIP.dat.gz , extracted the file, then replaced WhatPulse’s 0kb GeoIP.dat file with the downloaded version.
That fixed it for me

You can also remove the file, which will make the client download it again. There’s additional measures in the 4.0 beta to prevent the crash from happening: Login | WhatPulse