Startup crash on WhatPulse 2.0.1

I just updated to WhatPulse 2.0.1 on both of my Windows 7 SP1 x64 systems and am reliably seeing a crash immediately on attempting to start WhatPulse. The crash occurs as soon as the “Welcome to WhatPulse” wizard is displayed but before any interaction can actually take place.

The crash is of type STATUS_ACCESS_VIOLATION (0xc0000005) and appears to be occuring within WhatPulse itself (whatpulse.exe) and not a DLL module. The running account does have Administrator access but the system has UAC enabled. Running WhatPulse explicitly as Admin to bypass any need to potentially elevate the process results in the same crash at the same time.

I’ve pasted the “Problem signature” details from the crash below and can provide further details to help diagnose the issue if requested:

Problem Event Name:	APPCRASH
Application Name:	whatpulse.exe
Application Version:
Application Timestamp:	50e1983c
Fault Module Name:	whatpulse.exe
Fault Module Version:
Fault Module Timestamp:	50e1983c
Exception Code:	c0000005
Exception Offset:	0009fe53
OS Version:	6.1.7601.
Locale ID:	3081
Additional Information 1:	0a9e
Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
Additional Information 3:	0a9e
Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

I have got the same problem.
did you also not install the wincap program?

[quote="_[GoT]Jewest, post:2, topic:11042"]
I have got the same problem.
did you also not install the wincap program?

Correct, but only because I already have the latest version installed from an existing installation of WireShark (WinPcap v4.1.2 I believe). The installer did detect this for memory. Output below showing it’s running:

        TYPE               : 1  KERNEL_DRIVER
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

Same thing for me; it crashes continuously at start up. I also did not install wincap the first time, because I have wireshark installed.

I tried reinstalling both whatpulse and wincap, but it did not fix the problem.

Edit: I also use windows 7 64-bit.

:dodgy: I hope its the same like this screen…

It’s exactly like your second screenshot WildHogs with the startup wizard.

2.0.1 Doesnt work here either :frowning: 2.0 worked fine but sadly its not available on the site anymore :S


found i still had the old client install (2.0) in my download folder, after installing that one it works fine again.

didn’t reinstall the pcap driver so i’m pretty sure it wasnt in that.

Platform: Windows 8 x64
Username: WildHogs, ‘else on this form id’

[size=x-large]Windows Error Reporting Details:
[/size][code]Level Date and Time Source Event ID Task Category
Information 06-Jan-13 11:59:40 AM Windows Error Reporting 1001 None "Fault bucket -960069430, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: whatpulse.exe
P3: 50e04807
P4: whatpulse.exe
P6: 50e04807
P7: c0000005
P8: 0009fcdf

Attached files:

These files may be available here:

Analysis symbol:
Rechecking for solution: 0
Report Id: 6fbe040e-57ca-11e2-be7d-1803739792b9
Report Status: 16
Hashed bucket: 9ec0165460d9c6d581d868f5372d5fc2"
Attaching the file’s as in the details.

[size=x-large]Application Error Details:
[/size]Level Date and Time Source Event ID Task Category Error 06-Jan-13 11:59:35 AM Application Error 1000 (100) "Faulting application name: whatpulse.exe, version:, time stamp: 0x50e04807 Faulting module name: whatpulse.exe, version:, time stamp: 0x50e04807 Exception code: 0xc0000005 Fault offset: 0x0009fcdf Faulting process id: 0x1440 Faulting application start time: 0x01cdebd2931b6029 Faulting application path: C:\Program Files (x86)\WhatPulse2\whatpulse.exe Faulting module path: C:\Program Files (x86)\WhatPulse2\whatpulse.exe Report Id: 6fbe040e-57ca-11e2-be7d-1803739792b9 Faulting package full name: Faulting package-relative application ID: "

[align=center][size=large]I Hope This Information is going to help developers to fix the problem. [/size][/align]:dodgy:

This has been fixed in 2.0.2.