[SOLVED] WP 2.1.1 AES function not available???

Hi all,

I’d have never a problem with running whatpulse but this time there is a problem. On every boot Whatpulse suppose to be running. But now it is saying:

AES functions not available. Is OpenSSL library present?

I found another topic about this error, however I’m not running windows server software. This is what i run:

  • Ubunut 13.04 x32
  • Cinnamon desktop 1.8.2

To the best of my knowledge there is no software that can interfere with whatpulse (it never did) except OpenSSH server. I have no anti-virus or what-so-ever running. Also I checked on the error of having any libs installed regarding openssl.

user@user-laptop:~$ sudo dpkg --list | grep libssl
ii libssl1.0.0:i386 1.0.1c-4ubuntu8 i386 SSL shared libraries

I ran the same command for openssl:

user@user-laptop:~$ sudo dpkg --list | grep openssl
ii openssl 1.0.1c-4ubuntu8 i386 Secure Socket Layer (SSL) binary and related cryptographic tools
ii python-openssl 0.13-2ubuntu3 i386 Python 2 wrapper around the OpenSSL library

It appears that the software is there. Can someone help me on this? I tried to run the permissions file and downloaded the latest version for my distro.

Thanks in advance!

Dokter Computer

As per the installation instructions (http://whatpulse.org/kb/content/7/15/en/linux-installation.html), you need openssl-devel (or libssl-devl). Install that and you’re good to go!


Thanks, it worked. At first I could not find the packages mentioned but I found what I needed.

For other users having this problem execute this command:

sudo apt-get install libssl-dev

And you are good to go.

Once again, thanks.