Shut Down

I updated to the newest version. 2.0.4. On the Mac. Then after 2-3 hours it crashed and refused to reopen. I restarted by computer multiple times and re-downloaded the client a complete times and it still will not open. Why not? Help.

When should we expect a fix? I’m currently not running any version of WhatPulse because I only had the newest. Loosing all this time

The thread eTheBlack linked to is for Windows only. What error message do you get when starting the client? If you run it via commandline (, you’ll get some debug information.

this is the error I get

-bash: syntax error near unexpected token `’

I meant the error you get when you run it normally. That error is clearly the result of a wrong command.

You’re not copying the ()'s with, are you…? In any case, you need to be inside the Applications directory and then you should be able to tab-complete the path to the executable.

When I double click on the WhatPulse icon in the application folder it expands like it usually does when it opens, but then the icon does not show up, nothing happens, and it does not show up on the activity monitor.

I tried to tab over to the specific location that you specified but I can not find the contents folder

If the ‘Contents’ folder does not exist, that is your problem right there. Something must’ve gone wrong on your system which led to the deletion of that folder…must say I’ve never seen something like that happen before.

Delete the current and reinstall it, that’ll fix it.

I did that and now I can access the contents folder. I ran the operation in terminal with the following result:

Opening database file: “/Users/14savastano/Library/Application Support/WhatPulse/whatpulse.db”
Opened database in: 820 ms
“/Users/14savastano/Library/Application Support/WhatPulse/whatpulse.wpw”
Starting NetworkMonitor…
NetworkMonitor: Starting interface 4
pcap thread started on interface “en0”
Segmentation fault: 11

[Process completed]

so what do you suggest I do? please help

To be honest, I don’t really know. I think there’s something up with your system, because of the random ‘Contents’ directory that was deleted from an app.

You could try to delete the 2 files (the whatpulse.* files in de Application Support directory) and see if that helps any.

okay :frowning: thank you for your help

will there be any new updates soon?