Error while pulsing!

Since yesterday I’m not able to make a pulse, the following error occurs: “SSL errors, something fishy is going on!”
I’ve restarted the client several times.
This is happening on my two computers, both running Pop!_OS 21.10, with client version 3.6.
Can anyone help me?

I have the same problem. and it has been happening for much longer with me. still can’t find a fix. tried to reinstall the client but no luck.
I am also running Pop!_OS 21.10, with client version 3.6

Same here on Linux Mint 20.3, client v3.6.

I made the mistake to upgrade my snap on xubuntu 20.04.2 LTS from 3.1 to 3.6 and logged out from whatpulse because I got similar errors in 3.6. Now I can’t login anymore with the same SSL error message the original poster gets:

Edit: Oh, and I didn’t get redirected to the website to login, as happened to me on my windows 10 laptop.

My logging contains the following:

19-02-2022 21:45:52.194 DEBUG SSL Errors: 19-02-2022 21:45:52.194 DEBUG "The root certificate of the certificate chain is self-signed, and untrusted" 19-02-2022 21:45:52.194 WARN void ClientCommunication::checkHTTPError(QString) Error: "SSL errors, something fishy is going on!"

This is already going on for several days, so waiting for SSL certificate refreshes etc. is not working either.

Just chiming in to report the same behavior runing 3.6 on several linux distributions.

Thank you all for the feedbacks. And then the question is, does the WP team have a forecast of when this situation will normalize or do we have any way to get around this?

Same behaviour for me on 20.04.1-Ubuntu with 3.6

I just reinstalled the snap, because I saw with ‘snap info whatpulse’ that a newer version (3.7) is available.
This version seems to solve my problem with the login and also it allows me to pulse.


Can confirm, forcing the update to 3.7 with ‘snap refresh whatpulse --devmode’ worked. I’m able to pulse again!

Thanks my friend for the update tip… now it’s working again! Thank you again!


Just upgraded whatpulse from 3.7-`1 to 3.7-3 on Arch and that fixed the issue.