Duplicated pulse bug (DST related?)

Ok something weird and kind of dumb just happened to me last night. For reference, I’m fully up to date; running whatpulse 2.2.1, using win7.
So I was going about my business and suddenly I see this error dialog for whatpulse pop up saying something to the effect of “Pulse throttled; your last pulse was 0 seconds ago.” So I’m like “Wtf, how could this happen given my autopulse settings?” I check my client window, and I see that somehow Whatpulse seemed to have pulse after 1 hour uptime as I configured but it didn’t reset the local unpulsed statistics. o.O
After restarting the client (because before doing this it would let me pulse due to activity throttle) I unwittingly tried pulsing again and it worked. Much to my dismay however, I discovered when looking at the website that I effectively made a duplicate pulse. Or so I thought…now I realise that it seems like it has something to do with DST.
These are the two pulses

Notice how close in time they appear to be. But really, that’s only because of DST ending I now believe.

Not sure how this can be called a bug, as it did exactly what you configured it to - only you got an extra hour last night.

Well, should it not run off UTC or something internally? I mean, the fact that the clocks “went back an hour” meant that it wrongly believed throttling was appropriate.