Clarifications on RDP

Hi everyone, I’m using WhatPulse 2.4 on Windows 7 Home Premium Service Pack 1. I’ve installed the client on the laptop I work because I pass there most of my time and I was curious about the stats.

Now, since I’m a programmer, I word via Windows Remote Desktop which connects to another computer where there is installed all the stuff we need to work.

Long story short, when RDP is in full screen, keystrokes aren’t detected and therefore not counted in my stats.

How do I solve this? In some threads it’s reported as a problem, in some other it’s said that this is made by purposal to avoid cheating(???)

In the end, how can I make it work on a fullscreen RDP? (I cannot work in a cropped RDP screen otherwise I would have to continuosly scoll rdp screen up and down)


It kinda depends on where you have the WhatPulse client installed. If you have it installed on the Windows you’re connecting to, the stats are not counted by design.

If you have it installed on the laptop you’re using to connect to the remote Window to, it should work. If it does not, try enabling “Run as Administrator” in the client settings. The remote desktop client has a habit of elevating to a higher user level when for instance disk drive mappings are enabled.

Sorry if I wasn’t clear enough.
Well, the WhatPulse client is installed on my laptop, from which I connect to the RDP client to work, so it’s installed on my windows copy. The RDP windows is developement environement, so nothing “foreign” can be installed on it. And that’s what I wanted, I wanted to count my own keystokes and mouse click.

I tried to check the “Run as administrator” option in whatpulse, but to no avail. I tried also right click → run as administrator and also to check the run as administrator option in the security settings of the executable (right click, properties, compatibility, run as administrator check box).

Nothing, I can’t get the rdp keystrokes recording to work, while click count it’s fine even with fullscreen rdp.

What else could be? What can I try?

Thanks for the help, very appreciated

Here’s a few screenshot that might help…


Click/keystrokes tracking data:

As you can see RDP it’s opened as an external application, WhatPulse it’s not installed in the remote machine

Settings screen:

Any help???

I did a quick test and found out it is not to my liking, and IT IS CHEATING.

Remote desktop full-screen: local computer records nothing, remote computer records all.

Remote desktop windowed: local computer records all, remote computer records all.

Where is that bug tracker?