2.4 (Lubuntu) network stats problem

I have a problem getting the network stats in WP.

Strange enough it does work when i close WP and start it again with a SUDO; then up and download are counted perfectly. If i set the ‘start on boot’ option while in sudo mode; it doesn’t work, just like it didn’t work before.

I’m currently running wp from /usr/bin, in the past it ran from /home/%user%/.local/share/applications with the same problem.

also; when i look at the network tab; there it sees and counts traffic while i’m not in sudo mode; but again this traffic is not added to the pulse totals.

So it’s clear it CAN count, but currently it will only do so in SUDO mode; what can i do?

I guess it has something to with userrights, but since i’m quite new on linux/ubuntu i don’t know how to fix this on my own.

i found this info:

[quote]The next is only required on clients earlier than 2.1 - later versions will automatically correct this:
After libpcap installation, you need to tell the OS to allow the WhatPulse binary to hook into the network traffic. To do so, execute this command inside the directory where the binary resides:

sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse

but appearantly it also is needed for 2.4 as this solved my issue immediately

Only on not-tested distros. Currently, only Ubuntu and Debian are a tested distribution.

Running Ubuntu 13.04 and have recently been having the same issue as OP until I found this thread. Ran the command given by bogy and now it works perfectly. I ignored it before as it says it wasn’t needed for the v2.4 client.