WIndows High CPU Usage

Hello, i have installed V 2.5 and since the update it seems that it has a small problem, after some time, the monitor get’s stuck, cannot enter it whatsoever and the CPU it’s too damn high.
To resolve it, i have to close the app from the Task Manager, and restart it.

Platfomr: Windows 8.1 64

Edit screenshot:


Please uninstall WinPcap to see if that fixes it. If it does, reinstall that from:

I have the same issue. I reinstalled WinPcap now and check whether it fix the problem.

Seems to work fine now! :slight_smile:

I was happy too early. CPU usage is high again.

I still have this issue. CPU percentage is constantly 25%. It usually occurs when laptop is battery powered

Exact same issue here, Windows 8.1 but some difference.

I’ve got no problem when running it battery powered. Only when I plug it in the fan starts spinning and if I check indeed WhatPulse is using about ~13-15% CPU.
The icon stops working in the windows bar in the left bottom corner and with killing it in Task manager it runs just fine again.

I almost never quit my laptop but usually put it in hibernate.

I will try reinstalling winpcap and report back.

Having the same problem, tried reinstalling winpcap which accomplished nothing. Running it on an old Vista x64 laptop.

When you’re having these issues, please try to test a bit with disabling the stats types. For example: disable input, restart the client and see if it makes a difference. If not, then disable networking, etc.

After reïnstalling winpcap on 10th march I haven’t had any issues since, until now. Testing again with disabling network, I assume disabling stats will remove those from my stats from now on?

I am still experiencing these issues on my MSI 7REX, even started a separate thread, it’s annoying.

I have recently run into this problem and it seems to stop when I restart the application. However, when I turn my computer again whatpluse will start using high CPU usage again. Are you still having this problem?

Seeing the exact same behavior as @LiveTechToday.

CPU is pinned (using one full thread) on startup, but killing and restarting returns it to normal.

Technical details to help with debugging:

I didn’t have any issue until the recent update to 3.0 (It was maybe a week ago I was prompted to update? WhatPulse doesn’t usually prompt me, so I went ahead and OK’d it.)

Appears the new version has a spinning thread somewhere, that only gets hit when autostarted.

This happens pretty consistently, I’m pretty sure it’s happened on every restart so far.

It looks like this happens when there are multiple clients registered in the Windows startup settings. I’ll put in some code to make sure there’s only 1 client in the Window startup for 3.1, but in the mean time - you can fix this by removing both of them from the Windows settings, then toggling the startup option in the client to restore the single startup setting.

The disabled one of the two Whatpulse clients and now it seems to work fine. There are 4 clients names ‘Program’ without publishers and start-up impact not measured which I disabled now. Would those programs have an effect on Watpulse?

The double start-up, resulting into high CPU, should now be fixed with 3.1. Use the updater to get it, or download from here: