"Windows cannot find 'updater.exe'" error when updating

I’ve received this error any time the past few months that I’ve tried to update to a new version.

Picture: http://i.imgur.com/4Ara6L5.png

The odd thing is that there is an updater.exe in the Whatpulse folder (C:\Program Files (x86)\WhatPulse), but for some reason it’s not being found in the automatic update process.


[list]
[] WhatPulse version: 2.1.1
[
] OS: Windows 7 Home Premium x64
[] If you are using version 1.6 or higher, are you logged into an administrator account on Windows so that WhatPulse can access Windows correctly?: Yes (I only have one account on the computer)
[
] What error messages are you receiving (if applicable)?: “updater.exe: Windows cannot find ‘updater.exe’. Make sure you typed the name correctly, and then try again.” (See above for picture)
[*] What programs were you running when the issue happened?: Microsoft Security Essentials, Dropbox, Logmein’s Cubby, VirtuaWin, Rainmeter, ClipX, and Zhorn Software’s Stickies running at all times; Google Chrome is often open as well.
[/list]

I had the same problem with this last update into 2.2. I just went to the site and re-downloaded the program. It seems to have fixed the problem for now. (I guess we’ll find out when the next update comes along.) Just reinstall the program from the site. Make sure you have exited out of your currently installed Whatpulse Version. Oh! And don’t reinstall WinPcap. There will be a prompt in the installation process. the new version should just overwrite the older one, so there’s no going back and deleting old files. Hope it helps! :wink:

Yeah, unfortunately that’s what I’ve had to do for every update so far - manually update via the website (though today I found out that there actually is an updater.exe in my Whatpulse folder so I can go that route as well, but obviously neither should be necessary for something that’s supposed to be automatic). Hopefully 2.2 fixed the problem, I guess we will find out :stuck_out_tongue:

You can also just run the updater.exe directly as well. I believe the path cannot be found either because you’re running it in administrator mode, or because of the (x86) in the program files. This will both be fixed in the next release (2.2.1).

I’ve had the same error, even got it when trying to update to 2.2 but after quitting and reopening WhatPulse I managed to update to 2.2. But now I get this new error when trying to update to 2.2.1:

http://i.imgur.com/IcrD5JE.png

Translation:
updater.exe - Base/starting point wasn’t found
Procedure starting point _Z17qt_message_output9QtMsgTypePKc was not found in DLL library QtCore4.dll.

I think I’ll reboot my PC and see if it work and will of course report back when I’ve tried it :slight_smile:

EDIT: It didn’t help but @smitmartijn gave me the solution :slight_smile:

Rebooting won’t help - it means you’ve had the beta installed at one point and the updater.exe is still from the beta version. Just reinstall from http://whatpulse.org/downloads/ and you’re good.

But won’t I lose all my local stats? Or is there an option to keep them? :frowning:

No, you won’t. Unless you actually uninstall the client and say ‘Yes’ when the uninstaller asks you whether you want to remove the local stats. Otherwise the new client will just detect the existing database and login and continue like nothing happened.

So I’ll just install it again without uninstalling it?
EDIT: Yes.