Windows 7 Beta + Whatpulse

Just incase the devs dont already know

it doesnt log keys or mouse clicks, just movement (miles) and u cannot access the menu (right click) to pulse

Edit: Nvm, on a restart the keys/clicks started counting.

Windows 7 is some time off being finished at the moment. WhatPulse still isn’t completely compatible with Vista, however when development resumes it will be compatible with future versions of Windows (except pre-release versions).

Thanks for letting us know, though. :slight_smile:

Works fine here without any problems (on 64 bit), but you must set write access for user to the whatpulse directory

This is pretty trivial, but I’ve opened a ticket for it anyway. Will probably look more into it after the RC is released (maybe in April?).

I’m running Windows 7 as well and I noticed that my click count wasn’t going up. My key and mile count seem to be working fine though. Exiting and restarting Whatpulse fixed it, but it seems to be a recurring problem for me. I have it set to auto-pulse when I get to 10,000 keys, and for a few of those pulses, it doesn’t have any clicks recorded. I’ve now set it to also pulse when I get 2,500 clicks, so I’ll be able to see if it ever stops counting keys too.

I really like Windows 7 but may go back to Vista if this is going to keep happening. :sad:

EDIT: It seems that certain programs trigger the problem. One that I know for sure is the Fraps installation .exe. As soon as I run it, Whatpulse stops counting my clicks until I restart it. Obviously this isn’t the only trigger, because I don’t run the Fraps installer every other day and the problem keeps happening, but I’d say there’s a decent chance that the other triggers are related.

Here’s something that I noticed: It looks like it’s related to the UAC/“Do you want to run this program” prompts. I just installed something, and lo and behold, clicks stopped counting.

Is this on 1.5 or 1.6?

1.6. Same problem with 1.5

Alright. Well, when they release an RC or the RTM and everything is working how it should I’ll have a look into it.

There was a new build leaked out today.

Can’t post illegal torrent links here :wink:

Again, it’s still beta, I’d much rather spend time working on making 1.6 work as best as possible on XP and Vista before a beta. :slight_smile:

It technically wasn’t a link to the torrent, just to a blog that had a link to a forum post which talked about the torrent, still without a link. :wink:

Anyways, does Vista have the same problem? It would seem that if you had it working 100% on Vista, it’d work 95% on 7 at least.

Well I haven’t heard of any problems on Vista, nor have I had any personally, hence why I think with the changes M$ have done to the UAC in Windows 7, something’s still screwed.

same problem here with win7
lost already a lot of clicks,
i thought it was caused by my external mouse software because i couldn’t see where it was comming from
now i think about it, it happens more often while running lots of programs, and one of those is “not responding”
example, while 3D rendering the program isn’t responding while rendering. after these events clicks stop counting

Are you running administrator mode, loek0loek? Are you on x86 or x64 architecture?

FYI: I’m having a similar issue, however it’s not counting keystrokes or mouse mileage, only mouse clicks.

I’ve noticed that it doesn’t count anything when typing or clicking into a window that is running in elevated mode with UAC enabled (to test this, simply run notepad as administrator and type away). Somehow it also seems to stop counting mileage right then and there.

Changing access permissions to the programs folder where WhatPulse is installed didn’t change anything, unfortunately I don’t have time ATM to dig out a file access logger and see where else WhatPulse tries to put stuff :wink:
If the devels can pass out this info I’m more than happy to help.

Additional info:
OS: Windows 7 Beta (Build 7000), x64
WhatPulse v1.6

The account is an administrator account, UAC is enabled (set to default mode where it doesn’t nag around too much :wink: )

Hope the info helps


Run Whatpulse.exe as Admin and it works perfectly :wink: *(I’m running Windows 7 as well; just tested it)

Yea, that would solve that problem - however as I don’t run programs with elevated privileges very often I don’t care too much for it, as long as it continues to work in non-privileged windows :wink:

I’ll give it a shot though, thanks for the info :slight_smile:


I’m also suffering this annoying problem and running WhatPulse elevated, or turning UAC off is NOT acceptable. Those who advocate this sort of behaviour lead to the situation we were all in with Vista to begin with. It’s just sloppy programming.

There was a problem, I provided a solution. I’m not advocating any sort of behavior, just simply providing the answer to a question.