[Win8.1 x64, Pulse 2.5] Network device detected as inactive, traffic not tracked

Hi there. i ran into a strange problem. I have updated my laptop from 7 to 8.1 (clean format and reinstall) and now whatpulse is not behaving.

I noticed it is not tracking my network traffic, so i went to look. No netwok devices were shown in the list. If i untick the show only active button, a wireless network device appears, although both wireless and ethernet devices are actually present in the machine.

When i test download something, the device shows traffic at WhatPulse app correctly, however since WhatApp think its inactive it does not get tracked as my traffic.

How do i fix this? The only option whatpulse gives me is to ignore the device, but it already is doing that - i want the opposite.

WinPCap installed properly according to instalation that came with WhatPulse. Im assuming its working as whatpulse actually sees the traffic, just thinks its coming from inactive device.


If you’re seeing traffic being measured when you download something, it has to add it to your totals. The only exception might be the unpulsed counter, as that requires a functioning WinPcap installation. If only the unpulsed counter is not going up, WinPcap is not working properly. You can have a look at the app.log file the client keeps for any mention about WinPcap.

I am only seeing traffic if i uncheck show only active interfaces marker. The traffic does not get added to either summary at the bottom of interface window nor to unpulsed traffic. when the program pulses (i got set it to pulse every 24 uptime) it pulsed 0up0down.

The app.log has a line:
13-01-2015 19:32:28.057 DEBUG Detected that WinPcap is not available and falling back to Windows APIs! No unpulsed online data this way! :frowning:

It also has A LOT of this too:

13-01-2015 19:32:27.276 DEBUG Query string: “INSERT OR IGNORE INTO settings (“name”, “value”) VALUES(?, ?)”
13-01-2015 19:32:27.276 DEBUG Database error: “attempt to write a readonly database”
13-01-2015 19:32:27.276 DEBUG Driver error: “Unable to fetch row”

The database is NOT set as read only in windows.

Edit: Poking further into app.log i noticed a line where it complained about not being run as an administrator. So i trued that and then reset the token just in case. Looks like its detecting and tracking my traffic now.

This is strange, as there was no need to run as administrator when this same machine was using windows 7. but thats workable unless UAC is going to pester me every time it launches which would be annoying.

Another thing popped up: 13-01-2015 20:10:50.369 WARN Unable to find videocard in our database with vendor “10DE” , device “0425” and subsys “30CC103C”
However the UI shows my GPU correctly. I guess that does not really cause any trouble so thats that.

Thanks for pointing into the right direction, the log is very helpful :slight_smile:

I’ve actually not encountered not measuring network traffic because of not having administrator privileges before, thanks for the postback!

Does it maybe have something to do with strict group policies or other privilege settings on your computer?

Not having admin privs is usually not an issue. The client is not complaining (although the sad smiley might tell you otherwise), kinda depends on your setup.

I guess it is possible that admin access has overridden the “read only database” problem which was the root cause. it was spamming the log with that message and i mean hundreds of times. now its gone.

All group policies on that computer is default so far, the only thing i can think of interfering with policies is StartIsBack since it is windows 8.1 so it has to be “fixed” to be usable. The account running it is an administrator account (though as you know windows does not really give administrator access to administrator accounts anymore) and is the only account on the device, so it shouldnt have problems with group policy. (though im aware that technically there is always “Admin” account, but i never had to utilize it for anything)

Altrough i may have ran into yet another problem. Sunday morning i noticed that tracked stats exceed the auto-pulse limit and tried to manually pulse. told me it couldnt contact WhatPulse server, fair enough, maintenance or whatever, ill just wait. and i forgot about it. now checking back i notice that the machine hasnt pulsed entire week. may have to confirm when i get to the machine but i think it may be having problems pulsing. both my work and my desktop machine is fine, however both of those are running win7, so looks like win8 is causing issues, as always.

Writing from that machine now. Pulsing works when i press pulse button. the token seems to be reset to strange numbers though and my gigabytes of keystrokes is gone (the stat i remmeber and easily notice its not there anymore). not sure whats going on now.

i got no idea whats going on. it seems to have a mind on its own. is there any debugers i should run that could help or something?

I’m not sure what your problem is, as you said in your previous post that you had it working fine…

The issue i was writing about originally is resolved now. It was working fine.

However 8 days ago it gave me a message that it had a problem connecting to WhatPulse server to do its scheduled pulsing. I though that was just a templorar network problem and did not give it much though. however it hasnt pulsed on schedule since then, and the program for some reason no longer starts with windows (the checkbox is set in settings). Since manual Pulsing works fine i may need more time to observe whats going on and report whether its a real problem or temporary one.

There was no entry about failure to connect in app.log. The locally collected stats reset themselves at least once that i can confirm. I know this is very little to go on.