win7 wp2.5 not starting at all

Since roughly half december (dated by the date of my last pulse which was on dec 2014), and I presume with the update to version 2.5 - as that was around that time - WhatPulse will not start on my system, at all. It doesn’t start on boot, and manually running whatpulse.exe will not start the client either. The icon does not appear in my taskbar, and task manager does not show whatpulse to be running.

I am running Windows 7 SP 1. I tried re-installing WP, however this did not work. Removing and re-installing WP did not work either - the client will still not start. The user account that I am on has full admin permissions.

Any ideas?


I believe I had this issue before, and I solved it by right-clicking the shortcut and clicking on “Run as Administrator.” This is purely anecdotal, so your mileage may vary. Let me know if that works.

Nope, unfortunately that did not work.

I’m assuming that Martijn will end up helping you out. I’d suggest uploading your app.log file to expedite the process, which can be found at C:\Users[YourUserFolder]\AppData\Local\whatpulse\app.log

Sometimes, there can be an extra WhatPulse subdirectory to go through to get to it (e.g. C:\Users[YourUserFolder]\AppData\Local\whatpulse\WhatPulse\app.log)

21-01-2015 15:29:18.162 INFO “Starting WhatPulse 2.5…”
21-01-2015 15:29:18.613 DEBUG Installed CrashRpt!
21-01-2015 15:29:19.493 DEBUG Database file: “C:/Users/Elanthiel/AppData/Local/WhatPulse/whatpulse.db”
21-01-2015 15:29:21.052 DEBUG Database check: “ok”
21-01-2015 15:29:21.054 DEBUG Opened database in: 1561 ms
21-01-2015 15:29:21.069 DEBUG Not running WhatPulse as Administrator! :frowning:
21-01-2015 15:29:21.069 DEBUG Encrypted file: “C:/Users/Elanthiel/AppData/Local/WhatPulse/whatpulse.wpw”
21-01-2015 15:29:21.078 DEBUG Loaded application aliases
21-01-2015 15:29:22.043 DEBUG Opening GeoIP database: “C:/Users/Elanthiel/AppData/Local/WhatPulse/GeoIP.dat”
21-01-2015 15:58:19.967 INFO “Starting WhatPulse 2.5…”
21-01-2015 15:58:22.402 DEBUG Installed CrashRpt!
21-01-2015 15:58:23.082 DEBUG Database file: “C:/Users/Elanthiel/AppData/Local/WhatPulse/whatpulse.db”
21-01-2015 15:58:41.094 DEBUG Database check: “ok”
21-01-2015 15:58:41.106 DEBUG Opened database in: 18058 ms
21-01-2015 15:58:41.131 DEBUG Running WhatPulse as Administrator! :slight_smile:
21-01-2015 15:58:41.133 DEBUG Encrypted file: “C:/Users/Elanthiel/AppData/Local/WhatPulse/whatpulse.wpw”
21-01-2015 15:58:41.157 DEBUG Loaded application aliases
21-01-2015 15:58:45.323 DEBUG Opening GeoIP database: “C:/Users/Elanthiel/AppData/Local/WhatPulse/GeoIP.dat”

^ The last two “starts” of WhatPulse.
Interestingly, the last start, it does mention that it is running as administrator, however, it does not appear to start - there is no whatpulse.exe process in the task manager, and no tray icon.


Any antivirus or other protection software that will kill the client for ‘listening to the keyboard’ ? There are some aggressive out there…

Not that I know of, and neither did I install something new around the time when this problem started - other than upgrading from 2.4.1 to 2.5.