Whatpulse starts up but doesn't work

This started happening a few days ago, when pc boots Whatpulse starts up but there is no window and I can’t use the icon in the taskbar. Clicking doesn’t help do anything, I need to go into the task manager to close the program. Manually starting whatpulse makes it work but I lose my keys and such everytime.

I run whatpulse 2.5
I have Win 7 Ultimate SP 1
The software I run mostly is Chrome, Steam, Hamachi, skype and utorrent.
I had no AV when the problem started.

I have reinstalled whatpulse but it diesn’t fix the problem. The last time I uninstalled it an error popped saying whatpulse was restarted 4 times in the last minute and that a bug report will be send.

Also, in the task manager there is a process named Whatpulse-watchdog.exe does anyone know what this is?

Added extra information.

When reinstalling, you gotta clear the folder:


Edit: Yeah, the whatpulse-watchdog.exe is a new component (since some versions ago); check out the attachments, screenshots:

Argh, the button Insert Into Post isn’t working for me; Firefox on Windblows x64.