WhatPulse 2.0.3


2.0.2 had a pretty nasty bug with pulsing without the main window open, this new version (2.0.3) will fix that and also address some more issues. You can install it over your existing client, make sure to pulse before installing it, just to be sure.

Download URLs:

Change-log for 2.0.3:

  • [Fix] Crash when pulsing without main window open

  • [Enhancement] Only use database file every 5 minutes, cache everything else. This should bring disk I/O usage to a near standstill.

  • [Windows - Enhancement] Don’t show a icon in the taskbar for the Geek Window

  • [Windows - Enhancement] Use another way of click/key detection which should not be stopped during high load fullscreen applications (mostly games).

  • [Windows - Enhancement] Count unknown (media) keys.

  • [OSX - Fix] Detect when computer goes into sleep mode and release lock on bpf device(s). This will make sure OSX won’t need to create extra bpf devices, which in turn will make the client ask you for your password to reset permissions on these new files.

  • [OSX - Enhancement] Replace menu icon with a more suitable one.

  • [Linux - Enhancement] Multiple CPU optimisations for better performance

Please leave your feedback in this thread, thanks!

[quote=“smitmartijn, post:1, topic:11408”]

  • [Windows - Enhancement] Use another way of click/key detection which should not be stopped during high load fullscreen applications (mostly games).[/quote]Yeah!! Finally I can play UT2k4 in fullscreen without having to restart WhatPulse after playing the game :slight_smile:

I am trying to figure out why it does not count keys when I have heavy Java CPU load. I will play around a bit to figure it out.

They might be just delayed.

Just tested it a bit more. The mouse clicks stop working, but the keys keep on working. I don’t know if it is because I switch between a touchpad and an external mouse.

Starting today, (not sure if it’s because of this version or not, but I can’t think of anything else I installed new today) my mouse goes out of control for around 4 secs every 3-5 minutes or so. When the cursor is visible it moves with a huge delay and just in a weird way in general, like it’s drunk; and while in a first person view where the cursor is invisible (and probably centered), my camera spins out of control in every direction.

Could this be because of the new mouse hook? Again I’m not sure if it’s even Whatpulse because I wasn’t paying attention on whether it started as soon as I started using this version or if it was there before installing it.

Running this new client for 1 hour and 21 min and I see it’s not counting keys and clicks anymore. Uptime is counted as well as traffic.
There is a red dot on right corner of whatpulse icon

Looks good! Thanks for bringing back the old menu bar icon style on the Mac client! I really like the dot in the corners on key/click.

I think I found out what stops the mouse clicks. It is a YouTube video at full screen or TeamViewer.

I know it does not count keys while you are in TeamViewer. The older versions did count in TeamViewer.

Edit: If I close the WhatPulse window, it gets a red dot in the tray and stops counting the keys.

Edit 2: It seems like the click randomly stops. I can’t really make it stop like I thought. I know for sure clicking on the X(Close) on the main window causes it stop counting tho.

I am using Windows 8 64-bit.

The last 3 version kept crashing constantly and now this new 2.0.3 version won’t even start.

I already tried a computer restart and full uninstall and reinstall.

Details from event viewer:

Log Name: Application
Source: Application Error
Date: 1/27/2013 6:46:10 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: Desktop-NewHome
Faulting application name: whatpulse.exe, version:, time stamp: 0x51051c44
Faulting module name: QtGui4.dll, version:, time stamp: 0x4f619b63
Exception code: 0xc0000005
Fault offset: 0x005cfd4e
Faulting process id: 0x274c
Faulting application start time: 0x01cdfcf0dc8fcaf1
Faulting application path: C:\Program Files (x86)\WhatPulse2\whatpulse.exe
Faulting module path: C:\Program Files (x86)\WhatPulse2\QtGui4.dll
Report Id: 1b52e7a0-68e4-11e2-bebd-485b39197391
Faulting package full name:
Faulting package-relative application ID:
Event Xml:



C:\Program Files (x86)\WhatPulse2\whatpulse.exe
C:\Program Files (x86)\WhatPulse2\QtGui4.dll

I get the same not tracking keys/clicks error as well.

I found another bug. I thought it might have been my CPU load that was causing it. I found when exiting it completely, it locks up for 30 to 45 seconds before it completely closes.

[quote=“Mattjsrules, post:10, topic:11408”]
2.0.3 version won’t even start.[/quote]

Same problem here on both Windows 7 (64-bit) and Windows XP (32-bit). Neither 2.0.2 nor 2.0.3 will start on either PC. Running as administrator makes no difference. Version 2.0.1 is working.


Faulting application name: whatpulse.exe, version:, time stamp: 0x51051c44 Faulting module name: QtGui4.dll, version:, time stamp: 0x4f619b63 Exception code: 0xc0000005 Fault offset: 0x005cfd4e


Unhandled exception at 0x67ccfd4e in whatpulse.exe: 0xC0000005: Access violation reading location 0x00000004.

2.0.2 only started crashing when it first tried to pulse, so I wonder if it has something to do with having built up a certain amount of stats. Pulsing with 2.0.1 and then trying the newer versions again hasn’t worked for me so far.

This version seems to be working fine with me.
I’ve been having a lot of issues with the previous version not recording my keystrokes accurately, but for some reason, 2.0.3 is working perfectly on my side.
I might not update it anymore cause this one is stable for me.
For people who’s having trouble starting the application, Un-installing and re-installing might fix the problem.

Thanks for the update.

Not 100% sure yet, but probably every time WP saves the .db file my puter freezes for 1-2 seconds. Maybe 5 minutes is a bit too much?

I’m in work now, so I’ll check it later on my home PC, to see if has the same issue.

After playing around, I think I figured out what was going on. I have tried uninstalling/reinstalling, admin, and all other things. Finally I had to uninstall it, and if it asks about removing its data, I clicked on “Yes.” Then I installed it and signed back in. Now it works great so far. I will report any more issues that I run into.

So if you run into issue, try uninstalling it like ZeroFreak said, but remove the data when it asks about it too.

Edit: I just found a bug. While in TeamViewer, it does not see the keys/clicks.

  1. Switching user/remote desktop issue which I’ve reported a couple of times. I’m really curious if this happens to others as well, but anyway, it happens to me and still the same with version 2.0.3. When Whatpulse ‘crashed’ after switch back to my account, I still can navigate menu and it count upload/download, but not keys/clicks.

edit: Whatpulse 2.0.3 count keys/click after switching account. But the GUI still crash to black borders.

  1. I uses Autohotkey to remap QWERTY to Colemak. And with Whatpulse 2.0.3, some keys don’t count. They are f, p and j, l, u, y, ; and r, s, t, d and n, e, I, o and k. And those are keys that are actually remapped. Keys that placed the same in both layout (a, q, h, m, and z, x, c, v, b) have no problem.

And the interesting fact is, if I run Whatpulse 2.0.3 while Autohotkey already running, it count just okay. The vice versa cause the issue.

This problem happens to both Win 7 and 8, and didn’t happen in 2.0.2. And without Autohotkey, everything count okay.

  1. As reported by others, I’m experiencing 2~3 seconds of lag every 5 minutes or when I closing Whatpulse.

While trying to figure out the TeamViewer bug with WhatPulse tonight, I ran WhatPulse as admin, and for some reason, it breaks the mouse click. It will still count the keys, tho. I have to reinstall WhatPulse to get it working working again.

There is another small bug. After installing WhatPulse and if you have “Launch WhatPalse” selected, it does not count the clicks at the start. You have to restart the app before it starts seeing the clicks.

I have just tried this version on my PC at work, but it still doesn’t appear to be auto-detecting the proxy like the old client used to. It just hangs while retrieving the list of computers, even with ‘Auto-detect proxy’ ticked.

Running Win XP SP3 with proxy settings set by an automatic configuration script under Internet Options.

2.03 Hasn’t fixed the error of WhatPulse not counting in games and has introduced (for me) a click registering error. I have had to reinstall 2.02 due to this.