v2.1+ Fails to Load with Windows

So, my whatpulse client is setup to automatically run when Windows starts up, but since the patch, its been failing to do that.

It crashes the second I load the desktop.

Windows 8 64bit Professional. It takes 7 or 8 tries after that to get it to load. I’ve ran it in compatibility mode, doesn’t change anything. I’ve ran it as Administrator, doesn’t do anything.

I think WP needs to release a bug addition to it, where it records all crashes, etc… If the program loads fine, don’t create a log, app crashes, log it. Lots of work, I know but it would help tremendously.

  • X

I’m having a crazy hard time to get WP to launch on both my main desktop and laptop as well. Both are running Win7 x64. However they seem to start up fine on my other two machines running Win7 x86. So this might be a 64bit thing. Haven’t fully tested it yet.

Running Win7 64-bits and haven’t had any probs. WP (v2.1.1) starts with Windows without a glitch…

Strange. I haven’t got any other machines to test it on. As of now, half of my computers run 32bits and have no problems on boot while the other half on 64bit have problems at boot.

My work around is to avoid shutting down altogether. I usually just hibernate my machines anyway so this is no biggy. But on the times I do a fresh boot up I:
-Open task manager
-Select ‘Show processes from all users’
-Scroll down to ‘whatpulse.exe *32’ and end the process
-Then I can easily start up the WP client again.

I’ve had to do this regardless if WP runs as admin or not. If I don’t do the show all processes step I usually cannot find it running under my account which is really strange seeing as I am running the one and only account on these machines.

Since you’re not the only one running WhatPulse on a Win7 64-bits OS (and since there’s no one else complaining about WP not starting with the OS), maybe check on some Microsoft Win7 fora and present them with a logfile or whatever they require to sort out what exactly is preventing WhatPulse’s start-up at boot…

Right, I’ve fixed it. Turned out to be something wrong with the scheduled task that I use to launch it on startup to bypass the annoying UAC prompt since I run it on admin mode.

Mind sharing that bypass thingy? Or did you disable that completely now?

Sure. I still use it to bypass UAC, I just had it set wrong.

I found this after looking for ways to bypass UAC prompts for any program. Basically, you create a new task in Windows Task Scheduler, tell it to run whatpulse.exe with the highest user privileges and schedule it for launch on startup under the triggers tab. Like so:

If you’d rather use a startup delayer like I do, you can ignore the trigger section and instead create a shortcut of the task. This is done by assigning the path:

C:\Windows\System32\schtasks.exe /run /TN "TaskNameHere"

Replace TaskNameHere with whatever you named your task. In my case that would be:

C:\Windows\System32\schtasks.exe /run /TN "WhatPulseSkipUAC"

Then you can put this shortcut into your startup delayer. That’s also how to run any app and bypass the UAC prompt. Just make a shortcut of the task and put it on the desktop or start menu. But make sure “Allow task to be run on demand.” is checked in the settings tab.

Hope that was clear enough for everybody. :blush:

The reason I was having startup problems before was because I’d set the task to “Run whether user is logged in or not.” I switched it over to run only when logged on and that fixed it. Strange since my startup delayer doesn’t run anything until I’ve logged in anyway.