v. 2.2 doesn't count internet traffic correctly

It is doing it again in new version 2.2

Please fix and test correctly before releasing new versions. Last version (non beta) worked great.


  1. Version 2.2
  2. Windows 7 x64
  3. http://i.imgur.com/nRpGq2y.jpg
  4. uTorrent

Nothing has changed (just added) in network measurements, so there’s nothing to fix. Either it can’t keep up with the traffic (CPU-wise), or there’s local traffic going through that peering.

Now is better, guess it can’t really keep up with traffic. But last stable version worked great, numbers were the same in uTorrent and in WhatPulse, now looks like WhatPulse can’t keep up with it. Even with lower numbers. There is no local traffic in peering, all uTorrent traffic comes to this local ip.

Anyway, this version is better so going back for a hundred or two KB/s is not worth it.
Just informing.

I don’t think it’s related to this topic much, but WP says I’ve uploaded 8.1GB on Tuesday, November 14, 1989… I think that’s incorrect as well.

Is your date and time on PC correct? It shows correct for me
“You have uploaded 410.05GB on Saturday, June 1, 2013!”

Nope, it is not few KB/s anymore, after some run (8 hours), it counts only half or even lower amount.

Difference is about 100GB :S
Anyone else with same problem? Seems I will just try complet uninstall, including data, and reinstall again. It might fix this. (after I wake up…)

I am new to this program. I have spent 10-12 hours trying to get it to report my correct upload & download numbers. No luck at all. the local client “sees” my P2P client but only records keystrokes and clicks. The web info doesn’t even list it as a program I have. Firefox is listed as an “Inactive” program on the website (my info) but again, only keystrokes and clicks are counted. What does get recorded by the local client and reported seems to be just the pings, no actual uploads or downloads. None of the 100’s of MB per day are being seen.
When I say I’ve tried. I really mean it… installed, re-booted, uninstalled, re-installed, installed separately, changed ownerships and switched around Administrators etc. etc.etc… tried many ways of coming online… used VPN & no VPN etc. etc. I think I will give up unless I see a fix here on this thread or there is a new WP.

I have the same problem. I tried to downgrade and install wp 2.1.1, but there i have the same problem. wp tells me i have currently 62 KB/s upload but my other programms tell me i have more.
here is a screenshot: https://www.dropbox.com/s/k47su3vpbhxaawu/Unbenannt.png

i think wp has problems with p2p traffic…

@whatthenaiser, try 2.0.1

It worked great for me, before I updated to 2.2 and on 2.2.1 is same thing (It is way off)

Here you can get 2.0.1 version: http://www.mediafire.com/download/87vbxgxfoc3la7b/whatpulse-win-2.0.1.rar

thx for your answer, i tried it and now the trafficstats are ok…

I guess my issue is something else. I’ve tried v.2.0.1, 2.2 & 2.21 & 2.2b4… with a variety of installs (clean & dirty) and re-boots and several versions of WinPcap. I’ve messed with admin. permissions, and I have tried running all of the above before log on, after log on, before VPN connect & after and with and without PeerBlock… I pass about 140 GB upline & down every month. Seems a slap in the face to see Whatpulse apparently reporting only pings as “network traffic” with clicks & keystrokes.
I’ve tried clean installs and registry cleaning and rebooted my computer a dozen times before & after & etc., etc. etc. … still no success.
The Whatpulse pays no attention to any 100MB+ files downloaded thru Firefox and ignores my p2p whether up or download. I do want to know what I’m doing wrong.

Maybe you can, but I wouldn’t. Without MD5 and/or SHA checksum(s) for the original files, imo it’s not such a hot idea to download this program from a third-party web site. :wink:

[color=gray]… but, no joke, for real.[/color]


I download from this site then made a backup there. If you don’t want, then don’t download. Just helping to fix this thing

my fritzbox shows me 33840 MB upload.
and i only see 15gb upload in wp-app.

so: version 2.0.1 misses half of the traffic, too.

in my opinion wp thinks that lot of p2p traffic is internal and doesnt count it.
i have no problem while i’m downloading something in my browser. maybe there are rules based on ip addresses and some ip ranges are internal for wp?


I tested to download something from my server. wp on my server shows my only 330 kb/s upload, and my download pc shows my a download over 500 kb/s.

here is a screenshot:

Dear All,

I’m currently facing the same issues here. WP 2.2 and 2.2.1 only captures a small slice of the real traffic. WP 2.1 works well, as long as i have a VPN connection established.

My PC is online with a global routable IP (e.g. and the traffic I generate is not to computers on the same local network (like

I’ve attached two screenshots. The screen throughput from WP 2.1 differs from the system monitor because of the spikes, this is not important.

There have been a lot of improvements to the performance of the networking measurements lately…anyone willing to give it a go, please try the latest build: http://whatpulse.org/forums/showthread.php?tid=3862

Tested up to 400Mbit p/s of normal and p2p traffic, but then again, our own tests have always gone properly.

okay, thx for your answer.
i tested it with a random torrent client and than i downloaded and share a linux os.

Excellent work on 2.3b1 … It finally works for me, tracking uploads and downloads … so far no glitches.
It’s tracking my browser and my P2P at the same time and all while using VPN.
Just what I wanted it to do.:slight_smile:

ooOPS … spoke too soon :-/

only worked for a day partially, then stopped counting network traffic both ways after 3-4 days
I’ve tried re-installing under quite a few scenarios, (see above posts).
Still nada
all the same issues.

And what were the outcomes of those tests? :wink:

@JumpinJohnny: thanks!

I just found a setting that fixed the problem for me…

I uploaded with 10MB per second (100MBit) and WhatPulse only showed around a few 100kB per second.
This is caused by a feature of modern (and/or “older” but more expensive) network adapters called TCP (Segmentation) Offloading (TSO)[1]. It basically allows the operating system and/or software to send huge packets to the network adaptor which itself breaks them down to smaller ones without letting the CPU do that overhead.
Disabling it solved the problem.

So I guess Pcap only counts those larger packets as one standard size packet which would explain the difference.

Will try to disable this with my linux machine as well - I was only able to do this under win7 yet.

Here is the fix for linux (this has to be done after each boot):

ethtool -K eth0 tso off
ethtool -K eth0 gso off

– this actually takes a moment to kick in since current connections are still in the old mode if you enable this…

Your Mileage My Vary :slight_smile:

[1] http://en.wikipedia.org/wiki/TCP_segmentation_offload