Updating WP to 2.1

When i updated WhatPulse to version 2.1 it gives me an error every time i try to start it.

Error when i launch from setup:

Error when i launch by clicking on whatpulse.exe

Also getting errors.

Back to 2.0.1 again.

I’m also getting errors, it has killed the application completely and I can’t start it up again.

trend micro flags all the WhatPulse dll’s as a virus.
appears to think that \AppData\Local\Temp\is-3V08H.tmp\whatpulse-win-2.1.tmp is suspicious, and treats all the files created by it as malicious

Not sure with what settings you’re running TrendMicro with, but it did not detect it when we tested it…try excluding it. (by the way, the path above is just the installer)

The odd errors for the other people; please remove the director %LOCALAPPDATA%\WhatPulse and try again. This can be one of the effects of the database integrity checks, which means your database is not integer.

Okay so i was sent here by someone getting the same error as the second poster.

I tried the fix you said, admin but it still does exactly the same, about the runtime closing it for some reason.


Also having the same problem. Deleted the local app data directory, but it didn’t seem to help. Also, the client still seems to have random crashing.

Yeah I noticed the random crashing too, so even when it was running I couldnt play games or anything incase it locked up :confused:

I was experiencing the exact same issue as detailed by other people in this thread on updating to WhatPulse 2.1 with the unusual termination error being received from the VC++ runtime whenever trying to start WhatPulse. Also, on receiving this error the process didn’t seem to always cleanly exit needing a manual termination via Task Manager or similar.

I seem to have resolved the issue by running WhatPulse as an Administrator. Subsequent execution of WhatPulse now works fine whether I elevate the process via UAC or run with standard privileges. It seems like after updating to WhatPulse 2.1 the first run tries to perform some operations which require Administrator rights and causes a crash if they aren’t present?

I just tried running as administrator, didnt work for me sadly :frowning:

I also had some issues which u guys still have.

All my applications where lagging and freezing each 5 seconds or something, deleted that WhatPulse folder in %appdata%local… Received the error we all had. After that I decided to do a clean install of whatpulse 2.1 and everythings works well…

So I recommend you all to uninstall whatpulse fully (don’t forget to pulse ofcourse), check if there is any file related to whatpulse with the windows search function in your explorer and delete them all if needed. Than do a fresh installation of whatpulse.

Problems solved.

I have the same problem. My complete computer freezes for some seconds…
I deleted the %LOCALAPPDATA%/WhatPulse directory, uninstalled WhatPulse with the uninst.exe and did a clear reinstall.

But the first start also causes this error… I installed to C:\Progs\WhatPulse. Don’t know how to fix it. I already did reinstalled all C++ runtime installations from Windows - didn’t help.

I’m getting the same runtime error that won’t let me start WhatPulse after I install it, whether or not I run it as an admin. I tried installing 2.1b3 afterward and it gave me the same error as well where it wouldn’t run at all, so I had to go back to an older version than what I was using before.

Where I can download the old one? Didn’t found the old setup anymore.

I added the installer to the exception list, and it installed just fine. hiowever, now it’s missing dll files. probably the AV again.
edit: yep, it didn’t install due to AV. ended up turning it off to install. works ok now.

Mighty be an anti virus issue… I’m glad I don’t use that shit. :wink:

Well, I am moving back to 2.1b3, that version is the most stable for me.
2.1 crashes to many times for me. Every hour it crashes.
But the beta worked fine. Almost no crash :slight_smile:


well, now it says mingwm10.dll is missing. happens whenever I reboot my computer.
win7 x64
trend micro titanium, standard settings. it sez it removed it yesterday at 11 pm, but I re-installed it today successfully, and the log doesn’t show anything.

edit: diving deeper into the logs, it appears that it did delete it. my AV is really going after that tmp file, soemthing about heuristics.

Im only getting what the second poster said; after restarting WP to check my premium had gone through correctly, after pressing “refresh status”, with no result.
Windows 7 Ultimate 64.bit.