Unkonwn Crash

This is a very strange crash because I don’t know how to replicate it; WhatPulse 2.0.4 just decides to crash out of the blue.

I have two systems this occurs on.

The first is a Surface Pro, and the second has the stats of:

Windows 8
i7 Quadcore laptop version clocked at 2.66 ghz ( I don’t remember the model # )
500GB HD
Quadro 2000M w/ Optimus.

One thing I have noticed is WinPCap. I was under the impression that WinPCap was causing the crash previously due to the fact it wasn’t 100% supported on Windows, so I kept it uninstalled until they released the official Windows 8 patch. On the Surface Pro, it’s happens every so often so I barely even notice it, but on my laptop it happens with an alarming frequency. But once I get rid of WinPCap, all the crashes disappear.

WINPCAP is not causing the problem. Version 2.0.1 that is using it too works a bit better (it only crashes once every two hours on my system) on Windows 8. I am disappointed that the developers haven’t added the Windows 8 problems in their current known issues list and it will probably takes ages before they release a stable version.

Version 2.0.4 crashes in less than 2 minutes. I’ve also tried running it as admin (which is a really foolish thing to do anyway) as suggest but it didn’t change a thing. So I am stuck with 2.0.1 that slowly kills my hard drive.

I’m fairly certain WinPCap is the issue with mine. The removal of WinPCap (By uninstallation) solves any problems I have with WhatPulse.

WinPcap -is- causing the problems, as it closes the network thread sporadically on certain systems, which WhatPulse doesn’t handle very well.

Not sure where you’re getting your sourpuss face from, but if you look around a little, you can see there has been a new beta since last week, which means we are in fact, working on it. Plus, if you look at the knowledge base, there’s an article mentioning that WinPcap is not supported on Windows 8. Luck have it that they released an update for that 5 days ago, which will be included in the next release.

In any case, disable networking and it’ll be stable.

Trying out the beta. Will let you know if things improve. So far so good.

ok many thanks guys. I’ll try the new beta. :slight_smile: