Ubuntu 16.04 and Libqt5

Hi everyone.
I used to be a Premium user, but since i’m not able to run Whatpulse again, i suspended my Premium account.
Why?
I’ve just switched to another Linux distro (Trisquel, which is based on Ubuntu 16.04), and the newest Whatpulse client does not support “old” libqt5 libraries, that are the ones installed in my OS.

So, i’m trying to run Whatpulse 2.8.4 on an Ubuntu 16.04 based distro, and this is the error i receive;

vanacksabbadium@Cyclops:~/Desktop$ ./whatpulse
./whatpulse: /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5: version Qt_5' not found (required by ./whatpulse) ./whatpulse: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version Qt_5’ not found (required by ./whatpulse)
./whatpulse: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5.9' not found (required by ./whatpulse) ./whatpulse: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version Qt_5’ not found (required by ./whatpulse)
./whatpulse: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version Qt_5' not found (required by ./whatpulse) ./whatpulse: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version Qt_5’ not found (required by ./whatpulse)

There’s no way for me to install newest Libqt5 libraries, they just fuck up my OS.
So, i would need an older version of Whatpulse.
What can i do? Thanks in advance.