Trouble with Whatpulse in Ubuntu.

I tried to run Whatpulse and got this error.

But when I went to try to download it, it looks like I already have it.

I don’t know how to use Linux that well. Can you please explain what I am doing wrong?
Er… I figured out the solution to my problem on my own. However, due to the way this page became formatted due to the large pictures I cannot edit it.

I thought if I deleted the pictures breaking the links I could then edit/delete this post as to not waste peoples’ time, but I didn’t log in before I uploaded them so I cannot do that.

Also my click on my track pad wont count.

Guess I am a failure all around.

Everything you need is in de kb:

The installation guides notes openssl-devel, not just openssl, that’s why you’re getting that error.

Alright, I got it all working on my Ubuntu machine. Thank you.

However, I just put linux on my Chromebook so I could use Whatpulse on it. On Ubuntu I would just use the software centre to install those libraries. Since this version doesn’t seem to have such a feature I need to learn how to do it with the Terminal, something I should probably know anyway.

I tried typing in ‘sudo apt-get install libQtCore’ but it says the file isn’t found. I assume that there is some obvious grammar issue here, but I don’t know it.

Chromebook isn’t currently supported (I don’t have one), the client will not run on it (cpu architecture).

Eh, it took a bit of work but I got Whatpulse working on my Chromebook.

It counts my keys and downloads, but not my trackpad yet. I can probably get the trackpad working too, but I’m burnt out.

Took me like 8 hours to get it working. Bleh, I need to learn computers better. -_-

Edit: Oddly, the trackpad is counted in the Chromebook environment but not in the Linux one. No idea why yet. I might just call it good enough and not mess with it any further. :slight_smile:

Could you kindly explain how you got it working? I have been trying for quite a while.

I don’t remember it enough to say it step-by-step since I was drunk when I did it.

First I enabled developer mode, then used a program called Crouton to install Linux, then I did something in the terminal, then everything was good.

Which Chromebook do you have? Don’t suppose it’s a standard ARM CPU type, right? Or is there an i386 emulator on there, that could explain the client being able to run?

Yeh that’s true. He might have the pixel or something.