SSL Handshake Error

(Description first, versions below)

I’ve started receiving the following error dialogue when attempting to report a pulse back:

Error while talking to website: SSL handshake failed. We recommend trying again in a little while.

My browser and curl don’t seem to have problems with the SSL cert on whatpulse.org. However, running whatpulse under dtruss, I saw the following output on attempt to open browser for login:

08-02-2020 10:17:30.497 DEBUG SSL Errors:
08-02-2020 10:17:30.498 DEBUG “The issuer certificate of a locally looked up certificate could not be found”
08-02-2020 10:17:30.498 DEBUG “The root CA certificate is not trusted for this purpose”
08-02-2020 10:17:30.498 DEBUG “No certificates could be verified”
08-02-2020 10:17:30.498 WARN void ClientCommunication::checkHTTPError(QString) Error: “Error while talking to website: SSL handshake failed. We recommend trying again in a little while.”

WP version: 2.8.4
OS: $ uname -a
Darwin [hostname] 18.7.0 Darwin Kernel Version 18.7.0: Sun Dec 1 18:59:03 PST 2019; root:xnu-4903.278.19~1/RELEASE_X86_64 x86_64

Me too, on both my Desktop and Notebook.

Same here
Windows 10
Client: 2.8.4

Had a same issue, restarting a application seems to solve the problem.

https://twitter.com/whatpulse/status/1226173037789220864

A system restart allowed a pulse after this error but the error returned when testing using a manual pulse. Curious issue, to the aps credit it has been a long time since I have encountered any issues.

In my Mac and in some Windows machine I still receiving the message. I’ve also seen some 503 error in this website. Hope the issue will be fixed soon

Same problem here on my Mac, even after restarting the app a few times. Please fix :slight_smile:

I’ve just noticed that after restarting I cannot even log in using my client - same error

Hey folks. We’re looking into the problem, I’m having it myself!

Please give it some time. The caching time seems different per computer; but it will be cleared eventually and you’ll be able to pulse. All stats are simply kept a little longer on the client in the meantime.

Now is working fine for my Mac. Just to give you a feedback. Thanks for the job!

I get this error for 25 days now, still no pulses going through, can anybody help?

This has been resolved ages ago. Follow the directions in this thread, or post more details around your issue & setup.

Whatpulse Version 2.8.4.
UserID 230891
OS: Windows 7

And I get the handshake error since 02.03.2020

I tried restarting, manually pulsing, automatic pulsing, waiting with no success.

Do you need any other information?

Hello, sorry for the necroposting.
I have the same issue since January 29th, 2020.

I use Whatpulse since 2004, at the moment i have over 762.000 unpulsed keys. I haven’t given much thought into this issue lately, since over the years i even forget that i have got that tiny program recording keypresses at times, but I’d really like to know if there is a way to keep my unpulsed keys from vanishing, since I wasn’t able to solve the issue by myself, otherwise i’ll just have to reinstall or use a beta version and give up on the unpulsed keys.
My client is set to pulse every wednesday, but as i could see it has failed every wednesday for 10 months. Other programs are working fine on the same PC. I’ve tried adjusting firewall settings, but no luck.

OS: Windows 8.1 Pro
WP version: 2.8.4

https://whatpulse.org/Dosphal

I’m currently ranked 15th, those keys would boost me to 14th :smiley:

Thanks in advance for your help

Daniel / Dosphal

edit: i’ve checked the app.log and it says this:

[quote]
02-11-2020 18:27:43.116 DEBUG SSL Errors:
02-11-2020 18:27:43.116 DEBUG “The root certificate of the certificate chain is self-signed, and untrusted”
02-11-2020 18:27:43.116 WARN void __thiscall ClientCommunication::checkHTTPError(class QString) Error: “Error while talking to website: SSL handshake failed. We recommend trying again in a little while.”[/quote]

Don’t know if it’s useful, but it has the same error over the weeks

EDIT2:
I’ve updated the client to the new beta version 2.9b2, it worked and kept my unpulsed keys and i managed to pulse those as well. I’ll leave this here, should anyone else have the same problem.

I have the same issue!

Please don’t revive threads almost a year old - start a new thread. This was fixed in November of last year; make sure you’ve updated your client since.