[SOLVED] Whatpulse doesn't record the enter button

I have tested all the keys on my keyboard and they are all working fine on the heatmap apart from the enter key. I am currently using WhatPulse 2.2, the version i was using before didn’t record my arrow keys, Home, Pg up, Pg Down or End keys. Now while I have been using the new version, none of my enter key presses have counted in the heatmap but have counted in the overall key count. I’m worried that it might throw off my heatmap in some way but I have no idea how to combat this problem.

Any help would be much appreciated. I haven’t found much help in the forums so far.

The only way it’ll throw off your heatmap, is that it won’t show the enter key highlighted. :wink:

I haven’t heard of this before, which enter key is it? And what keyboard do you use? And what WhatPulse version are you running? And what OS are you running? (basically the info mentioned in: http://whatpulse.org/forums/showthread.php?tid=810)

I too have this issue, the key registers(adds to the key count), but doesn’t show on the heatmap.

  1. Which version of WhatPulse are you running? 2.2.1

  2. What Operating System are you using?.
    Windows 7 x64

  3. If you are using version 1.6 or higher, are you logged into an administrator account on Windows so that WhatPulse can access Windows correctly?

  4. What error messages are you receiving (if applicable)?

  5. What programs were you running when the issue happened? None that can cause issues (I’m pretty sure), as it seems to be recent and I have not changed anything in months.

Heatmap for all: http://puu.sh/4xVme.png
Heatmap for week(When Enter key stops showing): http://puu.sh/4xVkr.png

I have the same problem and I think it’s ever since the 2.2.1 update. It’s on both my laptop and on my main PC. Enter shows on all, year, 6 months, 3 months and month but I have pressed enter zero times this week it says and that’s not correct.

Same issue here on both Win7 and WinXP. Neither enter key has any effect on the heatmap. I just tried v2.2b5 and it doesn’t work there either, so I’m guessing the bug was introduced when the Insert/PageUp/arrow keys etc. were fixed.

This will be fixed in the next version.