[SOLVED] Pulsing doesn't seem to be 100% atomic


Last night while I was asleep, it seems that one of my pulses went through and saved to the site, but this information wasn’t sent back successfully back to the client. Now I have over 8 hours worth of stuff (mainly bandwidth stats) that I can’t pulse since I’m getting a token error. This is the only computer I am using this profile on. No idea how difficult it would be to implement, but ideally the server should make sure the client is aware too before saving the pulse.

1) Which version of WhatPulse are you running?

2) What Operating System are you using?
Windows 7 x64

3) If you are using version 1.6 or higher, are you logged into an administrator account on Windows so that WhatPulse can access Windows correctly?

4) What error messages are you receiving (if applicable)?
Initially there was a bubble notification about a network problem with automatic pulsing disabled that I dismissed without making any special note of it; it probably had been there since the broken pulse earlier. When I try to pulse now, I get “Wrong token, did you use this profile on another computer?”.

5) What programs were you running when the issue happened? VM-ware and certain higher-privilege programs (antivirus) may cause compatibility issues.
I have about 130 processes running so I probably won’t list them all (especially when I assume this is a server side problem), but I do have VMware’s background processes running and I use avast! as my antivirus. Neither has given any problems in the past.

6) Include any screenshots if possible.
10h 57m is the time since my 2nd to last pulse (at 01:53am GMT).


The client makes sure it’s aware of a pulse before saving the result, there was a disruption in service this morning which probably caused your invalid token, seen a few users complaining.

I have the same token error on all three of my active machines, as all of them attempted to auto-pulse during the service disruption. Hopefully a solution is in the works. The client doesn’t allow for logging out and back in to refresh the token without deleting local stats.

The solution is to reset your token and pulse onward.

So the solution is throwing away the last (by now) 14 hours of data on each of 3 computers? Doesn’t sound like a “fix”.

A good compromise is to set your computers to autopulse more frequently, and then disable client network communication as soon as the website becomes unreachable (the client does this automatically, but there is also a setting in the client to do this). That way, you won’t lose as much data if another service interruption happens.

A service interruption shouldn’t cause data loss at all. My clients are all set to autopulse at least once every two hours. Auto-pulsing was disabled by each client when it failed to reach the website. The problem was that the tokens were invalid when the site came back.

Okay then, having such a system in place already makes sense. Will keep this in mind in the future. Hopefully such errors which cannot be solved without losing pulse data don’t appear too often :stuck_out_tongue:

I guess I’ll back up my WhatPulse appdata directories in hopes that I can somehow find a way to pulse those stats at a later date, and reset the tokens.

Still hoping for a solution for this that doesn’t involve data loss, though.

Luckily it doesn’t, the backend is pretty tight, but things happen. In this case a database table somewhere locked up and the database replication (multiple servers) went askew. Last time that happened was about 9 months ago.

Again, if you’re having any problems with a token after yesterday, please reset it and move on. I’m sorry that you have to do so, but there’s no other way, or a way to recover your single pulse.