[SOLVED] Profile picture uploading not working?

So I was deciding to add myself a profile picture. I download a picture to upload and it just happened to get stuck on saying “uploading…” Refreshed numerous times and tried checking my internet settings.

So I then attempt to see if it works on other image hosting sites. I uploaded to Imgur and it proceeded right away and it showed up. Odd. I go back to WhatPulse and try again, selecting the same image I tried to upload. And it still got stuck on the “uploading” message, even after about 3 minutes. I am positive my internet isn’t spiking and I did test if it worked on other sites.

Anyone else having a problem with it getting stuck trying to “upload” a profile picture?


It seems to work fine from Chrome, FireFox, Edge, IE (you get the point)…also on your account. Are you dropping the image or selecting it through a click on the profile picture? If you are dropping it, try browsing to the image instead after clicking the profile image upload.

Specifically, I am browsing through the files to upload. Internet Explorer 11 is what I am using.

Can you try another browser, just in case IEs security features are hallucinating?

So apparently it worked from my iPod, but not on my PC’s IE. Very strange. Problem all solved now.