[SOLVED] [OSX] Only measuring modifier keys


Already for a few months I have the problem that Whatpulse is only tracking the modifier keys (Caps / Shift / Ctrl / Alt). The only solution I read to this problem is to re-enable accessibility options for the client. I have now already done that in every possible way.

I have always been using the latest version, I’m also running OSX 10.9.5.

Tried following things:

  • Re-enable with client on
  • Re-enable with client off
  • Disable > turn client off > enable > start client
  • Re-enable > restart computer
  • Disable > restart computer > enable > restart client
  • Re-installing client > re-enable
  • Re-installing client after erasing all previous files using AppCleaner > re-enable

When I start the client with accessibility options disabled I get the message that I should enable it. When it’s enabled I don’t get the message, but it still is not counting all keys.

I have installed WhatPulse on a friends computer (also OSX) and over there it directly worked after the re-enable. Any one else with the same problem, or a solution?

Kind regards,


If you’ve tried all these things and it’s still not letting you properly add WhatPulse…there’s one last resort which should work. Do this in a Terminal window (with WhatPulse closed):

sudo cp /Library/Application\ Support/com.apple.TCC/Tcc.db Tcc.db.backup
sudo sqlite3 /Library/Application\ Support/com.apple.TCC/Tcc.db 'delete from access where client like "%whatpulse%"'

Then open the client again (it’ll complain again), then give it permission once again and it should be okay.

Thank you smitmartijn for your suggestion. I have tried it, but to no avail. The moment I enter the sqlite3 command WhatPulse is removed from the accessibility screen as expected. After opening WhatPulse it complains again as expected, and WhatPulse reappears on the accessibility screen. I give permissions once again, start WhatPulse, it does not complain anymore about permissions, but still is only measuring modifier keys.

So maybe the problem isn’t related with permissions? I already have tried to set different keyboard input sources (U.S. / U.S. Extended / Dutch). The keyboard heatmap is showing a Windows like layout. Maybe that is the problem?

Weird, it might be something else blocking the client then. Got any type of antivirus/system monitor/watchdog running? Otherwise I’m out of ideas. If you’ve got it correctly in the security settings, it should work fine.

The heat map is the same everywhere, unless you change the layout to azerty or one of the other available options.

Yes yes yes! Webroot SecureAnywhere feature secure keyboard entry was blocking WhatPulse! Thanks!

Feeling a little bit dumb now, but at least the problem is solved :slight_smile: