Snap fails on Manjaro Linux

Here is what happens when I try to start the WhatPulse installed fron Snap (whatpulse-linux-2.9b2_amd64.snap)


Gtk-Message: 03:38:50.179: Failed to load module "canberra-gtk-module"
Gtk-Message: 03:38:50.254: Failed to load module "colorreload-gtk-module"
11-12-2020 03:38:50.256  INFO "Starting WhatPulse 2.9-1915..." 
QObject::startTimer: Timers cannot have negative intervals
11-12-2020 03:38:50.299 DEBUG Database file:  "/home/madhead/snap/whatpulse/x1/.local/share/WhatPulse/whatpulse.db" 
11-12-2020 03:38:50.307 DEBUG Database check:  "ok" 
11-12-2020 03:38:50.308 DEBUG Opened database in:  9 ms 
11-12-2020 03:38:50.313 DEBUG Encrypted file:  "/home/madhead/snap/whatpulse/x1/.local/share/WhatPulse/whatpulse.wpw" 
11-12-2020 03:38:50.313 DEBUG Unable to open savefile 
11-12-2020 03:38:50.313  WARN Failed to load ' "/home/madhead/snap/whatpulse/x1/.local/share/WhatPulse/whatpulse.wpw" ' - trying backup file 
11-12-2020 03:38:50.313 DEBUG Unable to open savefile 
11-12-2020 03:38:50.327 DEBUG Loaded application aliases 
11-12-2020 03:38:50.327  WARN PF_PACKET is not available. 
11-12-2020 03:38:50.363  WARN Cannot open lspci-command 
Fontconfig warning: FcPattern object weight does not accept value [40 210)
Application crashed with signal 11!
0 [/snap/whatpulse/x1/usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/../../../ [0x7fd16108fa11]]
1 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd1684adb31]]
2 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd1684b11ad]]
3 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd1684b19d6]]
4 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd168487433]]
5 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd1684a8e11]]
6 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd168652fa8]]
7 [/snap/whatpulse/x1/usr/bin/../lib/x86_64-linux-gnu/ [0x7fd168653b10]]
[1]    91852 abort (core dumped)  whatpuls

I am receiving the same error.

I’ve been told that if you clear your font cache, it’ll work.

Thank you for your quick reply. Unfortunately this did not work. I ran fc-cache -fv and reinstalled the snap and am receiving the same error as pasted above.

Didn’t help me either :frowning:

It’s more than fc-cache -fv:

sudo rm /var/cache/fontconfig/*
rm ~/.cache/fontconfig/*
fc-cache -r


You shouldn’t need to reinstall the snap. This fixed the issue for me on Pop_OS! 20.10.

Still didn’t help with the same message as in first post.