SC2 not counting keyboard

I been using WhatPulse for a day now. And I was playing StarCraft II and when I’m in the game it only counts my mouse clicks and not my keyboard clicks, but when I minimize or tab out, it counts both perfectly fine. How do I fix this?

Try running it as administrator. There’s an option for that to make it easier.

running whatpulse or starcraft 2 on administrator?
i tried to run both on administrator and it didnt work

I had the same probelm. (2.1)
Then i have update WhatPulse to (2.1.1) and it works.

Please make sure that you are running the latest version (2.1.1) and that you are running the WhatPulse program as an administrator - otherwise, it will not be able to count your keys properly. Once you’ve tried this, let us know the results.


I updated whatpulse and it said that I was already using 2.1.1 and I have made it so that on the whatpulse properties, I am running it as administrator and in the whatpulse client to run it as administrator. I don’t know If i have to restart my computer or whatpulse but, I have tested it on starcraft 2 again and it still won’t count the key presses.

Have you restarted WhatPulse since making it run as administrator?


yes, i have restarted whatpulse since making it run as administrator and it still won’t count the key presses

Do you have multiple Whatpulse folders in your Program Files?

no i only have 1 folder for whatpulse