Quick question regarding the new heatmap

Is it a bug or is it intentional that free users no longer get a global heatmap? I’m a little bummed that I can’t view at least the global keyboard heatmap (I don’t really care about a per-application heatmap anyways), and I don’t really want to pay a subscription just to get it back.

This started after I updated the client, and I can’t even view the past heatmaps.


My entire global heatmap has died. I would like to know if this is a bug or intentional, and if it’s reversible.

Same here.
Updated to 2.6 today and from that exact moment the heatmap stopped functioning completely. Seems like an 2.6 issue to me…

Global keyboard heatmap doesn’t work for premium too as of now, at least for me, so it’s likely a bug.

same here - after installing the update 2.6:

the keyboard heatmap is not working, but the mouse-heatmap is working

Thanks for the update. I would think this bug is fixable so that all the heatmap data is permanently lost?

Could you try to disabling it and enabling it again? It should work fine and in all upgrade tests that were done, this was not an issue.

Just to be clear: the global heat-map was and is in the free client, the only thing that’s premium is the per app selection.

I enabled and disabled the heatmap at least 10 times
I changed keyboard layout couple times
I restarted my system twice

Whatever i do the heatmap just doesn’t work anymore after updating to 2.6

I tried exporting heatmap data to csv to see if it’s there, all keys are shown as 0s, but the SQlite db file seems to have them recorded, so I think it may be problem with only heatmap.

EDIT: I have reset WhatPulse completely (removed db and wpw files from localappdata along with backups) and logged in again in it and global heatmap began working again.

Keyboard Heatmap doesn’t work for me either. OS X 10.10, WP 2.6.

Just like michalpol I completely reseted WhatPulse, but for me this didn’t work, also (re-)enabling the Map and changing the layouts didn’t work.

And for Mac, there’s another small issue, pulses from 2.6. show the false OS icon on the website… just look at my profile and you’ll see what I mean…

I removed db and wpw files and logged in again but still no heatmap.

For the ones that it is not working, could you share your app.log for debugging?


I’m also unable to see the global keyboard heatmap.
Here is the part of my log with the update last night.


(I xxxxx-ed my Windows username and my MAC address in the log, the rest is unaltered)

Also having this problem, am free member. Here’s my data if it helps:


I’m also having exactly the same problem - keyboard heatmap stopped working with the new version, even though it’s still logging the quantity of keypresses. Mouse heatmap is fine.

Same problem for me as well… I don’t see how putting up my app.log for public view is going to help. So I’ll just ask; is there any fix and/or new update coming out soon? This is rather annoying. :expressionless:

well… just in case… http://pastebin.com/0mDaE4N5

I just pasted the app.log for today, after I updated the program. That’s good enough, yes?

Same problem, you probably have plenty of data already but but http://pastebin.com/YggiSLEF

This was generated immediately after uninstalling, wiping everything in Whatpulse’s appdata folder and performing a new installation.

I’m going to need a whatpulse.db from someone with this issue. Can someone upload/dropbox it somewhere?

Here’s my whatpulse.db file.