pulse timeouts

Is there any way around this when using port 80? I am unable to use port 3490 because Im behind a firewall that blocks everything on non standard ports. only web pages (80, 443) email, ftp, ssh are valid ports as far as I know. I assumed that the latest edition of whatpulse using port 80 would allow me to pulse again. But it seems it times out.

If I view the debug log, I can see the SERVER - Connected message when I try to pulse. Then it just sits there, and after 30 seconds I get the pulse timeout message.

None of my browsers or anything else use a proxy. But I’m guessing there is some sort of proxy to filter out data between me and the outside world, thats just a global network proxy. Not something that needs setup on each machine.

Am I basically out of luck, other then taking my computer to another network thats less restrictive to pulse?


The debug log is a lie, it doesn’t really connect :stuck_out_tongue:

I take it you’ve never been able to use WhatPulse on this particular network? (1.4.7 and down used port 80, 1.5 used 3490, 1.6 used 80 and now 1.6.2 uses both) - Just interested to know for my own purposes.

I can’t tell you much about setting up proxies and I don’t think anyone else here can, but you might want to just get in touch with a network administrator there to see if he can help you out.

If 1.6.2 worked properly on a USB stick, I’d say go for that method, however at the moment it doesn’t act how it should because it saves the file in %APPDATA%\WhatPulse. There are some steps, however, to run it off a USB stick:

  1. Install WhatPulse on a USB stick;
  2. Run WhatPulse from a computer that can access the internet, log in and finish setup;
  3. Start → Run → type “%APPDATA%\WhatPulse” and copy “WhatPulse.wpw” to your USB stick;
  4. On the computer you want to run WhatPulse on, Start → Run → type “%APPDATA%” and create a new folder called “WhatPulse”;
  5. Copy the “WhatPulse.wpw” file from your USB drive into the new folder in step 4;
  6. Run WhatPulse.exe from the USB drive.

When you’re ready to pulse, just replace the WhatPulse.wpw file on your USB drive with the one in %APPDATA%\WhatPulse, take it home, replace the WhatPulse.wpw file in your %APPDATA%\WhatPulse\ folder with the one on your USB drive, run WhatPulse, pulse, then copy WhatPulse.wpw back onto the USB drive to repeat!

Sounds a lot more complicated than it is, and you need to do the last part after pulsing to get the new token in your WhatPulse.wpw file.

I’m hoping to have proper USB support in 1.7, but until then, that’s probably the best way to do it.

Edit: Thanks for bringing this issue up - I’ve added it to the knowledge base now for all to see :slight_smile: http://whatpulse.org/kb/idx.php/0/058/article/Using-16-162-or-1621-on-a-USB-Drive.html

Thanks for the above post. I will be using this method to collect keystrokes whilst at college until 1.7 arrives or I get my new laptop. :stuck_out_tongue:


Way back when I could use 1.4.7. Or whatever an older version was. But that was a long time ago. you can check my pulse history. the “work” computer i believe shows how often I pulse. But when I moved to the 1.5s and 1.6 it broke. now with 1.6.2 its still broke. but i know the security on my work network has greatly increased over the years, so maybe it can tell that your trying to pass non http data over the http port and its gettign blocked.

I like the idea of the usb flash drive install. i never thought about running it like that. But at least my work computer is a laptop, that I do take home ocassionally. so when i have it at home on my own network I can pulse.

The one down side, is that I have a second computer in my office, that I can’t use whatpulse on. Because when I install it and try to login, it tries to connect to get the “computers” in my account. and that step doesn’t even work from inside my work network.

Stu: Follow my instructions above and you’ll be able to use WhatPulse on any computer, even if that computer doesn’t have internet.

1.4.7 didn’t use pulse profiles/computers, by the way. As I explained in my previous post about the ports, it’s probably your network not WhatPulse being broken.

I’ll setup the USB drive as you said and see how it goes.

I assume the wpw file stores your user account, and which computer profile its from. so even though I will be pulsing all my different computers through the same ones, they would be going to the correct profiles.

Thanks for the help.

Another feature yo umight want to try adding in for this USB support is the capability to have multiple computers supported from one USB install.

Meaning I have two machines that can’t pulse. One is my “work” profile, and the other is “work_server” profile. I swap back and forth between which one I work on multiple times a week. and it would be nice to be able to have an easy way to run them both without too much file transfer back and forth.

I suppose I could just install whatpulse multiple times on the usb stick and open up the appropriate one on the appropriate machine. But wasn’t sure if there was something you could try to add in for this functionality to make things easier.

Then again, I could be a very limited case, and not be worth the hastle to try and come up with something.

Just a thought.

[quote]4) On the computer you want to run WhatPulse on, Start → Run → type “%APPDATA%” and create a new folder called “WhatPulse”;

The computers at college disallow us from doing this and therefore I cant complete this method. Ah well. Guess Ill just save for a laptop.

You could just manually go to C:\Documents and Settings(username)\Application Data\WhatPulse (on XP… can’t remember what it is on Vista).

Yeh I did and the folders are read only.

I am currently in college and have once again tried this method posted above and this is the error in which I recieve:

I was aware to go to the folder manually, I am doing an IT course and have quite some knowledge in the subject hehe, however with the security mechanisms in place currently we are unable to create folders or files in any areas apart from our own USB disks and T drive which we are given with a small amount of space on the network to save work and other useful files. This does not include any application data and the drive cannot be used to run WhatPulse either.

There doesnt appear to be any more methods which can be used, and all the computers in the college are on the same mirror for the network.

Well if programs can’t access the app data folder then that’s too bad. :wink:

Just wait until the next release.

Will do dude. Cheers.

Thanks to Inquisitor911 I managed to get hold of a copy of WhatPulse 1.5, and can now use WhatPulse at college without any problems. Simply complete the pulsing at home, create new token, and then have it ready for the next day of college and switch back to 1.6.2 when using WhatPulse at home. A 20 second job once I arrive home for a good extra 10-20k keystrokes a day and maybe more depending on how much college work we get done and what work we have to do on that day.