Proxy Issues

Using v2.0.1 on Windows 8 Enterprise, I can’t connect to WhatPulse with our company’s proxy. I get an error informing of the connection being terminated prematurely. However, entering the same settings on v1.7.1 works perfectly fine.

I’m having that same error, with version 2.0.4 on windows XP when trying to connect through a proxy
Unfortunately I don’t have v1.7.1 to use

Anyone have any solutions?

I’m also still having this problem. The 2.0.x clients don’t appear to be able to use corporate web proxies; I have tried each of the 2.0.x clients as they have been released and none of them can access the Whatpulse server (can’t get past the login screen, and the test proxy button just freezes. The auto detect doesn’t appear to detect the proxy either).

I still have the 1.7 client installed on my main work PC. When I try pulsing from this I receive the message saying it can’t pulse because one of my machines has pulsed from a 2.0.x client, so the proxy itself is still working as it always has.

It would be amazing if this can be looked into in the next release since I use my work computers the most! Or would it be possible to allow pulsing from the 1.x clients for specific computers which haven’t yet had a pulse from 2.x clients?

What sort of proxy? HTTP? SOCKS? My work has an HTTP proxy (no authentication required) and the newer versions of WP have no problem with it.

I’m facing a similar issue. We have a proxy that works through an “automatic configuration script” (configuration in the Internet Properties of Windows 7). Since v2 I don’t seem to be able to pulse anymore. Configuring WhatPulse to auto detect the proxy doesn’t help.
When I try to pulse, I get an error message saying: “An error has occurred while communication with the website: Proxy server not found”.

Edit: Since I’m working at home today, I thought possibly my proxy wasn’t necessary now. So I disabled “auto detection”, but still couldn’t pulse. After quitting and restarting WhatPulse though, I could pulse!
I’ll try tomorrow at the office if I’m still able to pulse there… (I guess not :P)

Get the link to the automatic configuration script, open it in Notepad, and find the relevant settings in there so you can enter them manually in WhatPulse.

It’s all very well saying that, but doesn’t work in practice when the LAN menu looks like the attached (I can’t see the whole URL of the script)!

[edit]Before anyone suggests it, I have tried manually setting the the proxy within WhatPulse to and :8080, but to no avail. I still have the old client installed, it is still able to connect/login with no proxy settings set in the client, but obviously cannot pulse.[/edit]

If you can get to Command Prompt (Run → cmd), see if you can run one of these commands:

[code]reg query “HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings” | find /i “AutoConfigURL”

reg query “HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings” | find /i “AutoConfigURL”[/code]

(Based on the solution I found here: )

That actually worked amazingly (regedit is locked down), thanks! Unfortunately after downloading the script, the proxy server was indeed what I thought it might be (, which still doesn’t appear to work.

I think the problem must be to do with proxy authentication (i’ll have to trial and error a few things with my domain/login) or just an issue with my portable version of the program.

I’m not actually able to install Whatpulse due to the admin restrictions, so I installed it at home, zipped the installed directory and downloaded that from my server while at work (USB drives are blocked by the Data loss prevention app). I don’t know if that could potentially cause problems? I’ll re-try creating the portable application at home, making sure to enable portable mode and report back.

I guess if authentication is required, it would be your Windows username and password. Try including your domain followed by a backslash before the username when you enter it in WhatPulse settings: domain\username

Auto detect proxy is working for me in 2.1b1, when it wasn’t in previous versions, so upgrading to the beta might fix proxy problems for some people.