Problem with new installation crashing and how I fixed it


I haven’t posted here before but I wanted to report a problem I had and how I fixed it in case anyone else runs into a similar scenario.

I recently reinstalled 64-bit Windows 7 on my PC. I had backed up my hard drive before I reinstalled so I had all the contents of my user profile. Lucky for me or I wouldn’t have been able to get WhatPulse working again.

I installed WhatPulse and once the program started, I was prompted to put my account information in. Before I could complete the form, the program crashed. I clicked to report the error. I tried checking the information that was being submitted and the only thing I saw was there was a file that it couldn’t open in the ‘C:\Users<username>\AppData\Local\WhatPulse’. I tried checking the Event Viewer and I couldn’t find anything there.

I tried Googling for a few minutes and didn’t find a quick answer so I decided to try and copy over my backup of the AppData\Local\WhatPulse folder. Once I copied over the folder was my previous data, WhatPulse opened up with my account info in. It’s also recording data and working like previously.

I’d like to know if anyone has a better solution.

TL;DR - If you can’t get WhatPulse to work after a reinstall, I hope you have a backup your C:\Users<username>\AppData\Local\WhatPulse folder or else, you may be S.O.L.

This sounds like it would work, however sometimes this can cause a conflict/mismatch with the files. I believe it is called a token.

This is just what worked for me. I was reinstalling to the same hardware, just a new copy of Windows.

Crash and kabom! I dont have backup, surprise. :confused: What i can do?

24-02-2014 17:26:02.530 INFO “Starting WhatPulse 2.3.1…”
24-02-2014 17:26:02.561 DEBUG Installed CrashRpt!
24-02-2014 17:26:02.967 DEBUG Database file: “C:/Users//AppData/Local/WhatPulse/whatpulse.db"
24-02-2014 17:26:02.982 DEBUG Database check: “ok”
24-02-2014 17:26:02.982 DEBUG Opened database in: 15 ms
24-02-2014 17:26:02.982 DEBUG Not running WhatPulse as Administrator! :frowning:
24-02-2014 17:26:02.982 DEBUG Encrypted file: "C:/Users/
24-02-2014 17:26:02.982 DEBUG Unable to open savefile
24-02-2014 17:26:02.982 WARN Failed to load ’ “C:/Users//AppData/Local/WhatPulse/whatpulse.wpw" ’ - trying backup file
24-02-2014 17:26:02.982 DEBUG Unable to open savefile
24-02-2014 17:26:02.982 DEBUG Loaded application aliases
24-02-2014 17:26:03.560 DEBUG Opening GeoIP database: "C:/Users/
24-02-2014 17:26:03.591 DEBUG WhatPulse 2.3.1 has started
24-02-2014 17:26:05.588 DEBUG Starting timers and collector…
24-02-2014 17:26:05.588 DEBUG enableInputHook: true
24-02-2014 17:26:05.588 DEBUG Starting PcapNetworkTrafficMonitor…
24-02-2014 17:26:05.588 DEBUG LowLevelHookHandler starting
24-02-2014 17:26:05.588 DEBUG Enabling lowlevel input hooks
24-02-2014 17:26:05.603 DEBUG Found new interface: 11 “{043BCBE4-FAE2-4167-A3D9-A1B298136D14}” “18:F4:6A:C5:B0:B0” “Atheros AR9285 Wireless”
24-02-2014 17:26:05.603 DEBUG PcapNetworkTrafficMonitor: Starting interface 11
24-02-2014 17:26:05.634 DEBUG Setting WinPcap buffer to 4MB: “Success”
24-02-2014 17:26:05.634 DEBUG pcap thread started on interface “\Device\NPF_{043BCBE4-FAE2-4167-A3D9-A1B298136D14}”
24-02-2014 17:26:06.087 WARN QLayout: Attempting to add QLayout “” to FacebookLoginTab “”, which already has a layout
24-02-2014 17:26:06.087 WARN QLayout: Attempting to add QLayout “” to FacebookLoginTab “”, which already has a layout

Edit: Wow, i uninstal winpcap and now it´s in operation!!! It’s alive! :cool:

I wish I had kept a copy of my debug log so I could show but I know the developers have it since I reported that damn thing like 10 times.

Anyways, mine was crashing at “pcap thread started on interface”. That was the last line it’d show me in the log.

I never uninstalled WinPcap but I had installed Wireshark and it had 4.1.2. I thought maybe it was a problem with it being an older version since I saw a thread mention it and updated to 4.1.3 but didn’t have any luck.

I’m not sure what ‘whatpulse.wpw’ contains. I’d provide my copy here if I knew it wouldn’t just allow anyone to login and user my account on here. :stuck_out_tongue: