Premium Windows Client Not Detecting Keystrokes or Clicks

Hi,

I upgraded to the premium service today and whilst in the settings to refresh my premium membership in the client, I decided to enable the ‘Run as Administrator’. I restarted the client and it stopped detecting key presses and mouse clicks. The red blink in the icon never happens and the stats stay at zero.

Disabling the option and restarting the client has not worked. A PC restart hasn’t helped. I’ve tried uninstalling the client and deleting local settings, but I am logged back in now and it’s still not detecting anything.

I am actually accessing my PC through remote desktop. The local version of WhatPule is stopping as expected, and restarting it restarts stat counting as normal. It’s the remote client not detecting anything.

I also installed a load of Windows updates yesterday, so don’t know if that is related?

  1. WhatPulse 2.3.1.

  2. Windows 7 Enterprise x64.

  3. I am logged in using an administrator account. UAC is disabled as I’m in a corporate environment.

  4. No error messages, simply not detecting any keystrokes or clicks.

  5. McAfee 8.8 Enterprise antivirus; EMET notifier 3.0.0; Forefront TMG client installed but disabled. Internet access auto detects successfully (well it did, it doesn’t bother pulsing now there’s nothing to pulse).

Many thanks to anyone who can offer any advice.

~Cyrix

\Edit - I’ve attached my log file as a .txt

Hi,

The client does not count remote desktop connected sessions on purpose, as it can only count the keys/clicks generated by the keyboard/mouse.

Hi there,

As far as I am aware it is only the local client that does not detect keys/clicks, and this is to prevent cheating i.e. counting everything on the local and remote clients. I often work from home and I don’t ever seem to remember having a problem in the past?

However, should it in fact be the remote client that does not detect the keys/clicks, then my real problem is the local client (my laptop).

When first loading WhatPulse on my local PC it detects everything fine. Once I go into an RDP session however, it stops incrementing the counters, although it does still blink red in the tray. If I restart the local client it detects again, until I go back into the RDP session.

I thought this was by design?

As it stands, I am not getting any detected keys/clicks in either my local client of the remote client. Surely this is not right?

Thanks,
Cyrix

When you login to a computer via RDP/VNC/whatever and it has WhatPulse running, the input will not count on that computer.

If you also have a WhatPulse client running on the computer with which you’re doing the logging into (and are physically located behind its keyboard), that client will continue to count.

If the tray icon is blinking, it is counting, there’s pretty much no other way. The cheat preventions happen before it gets to the point where it blinks the icon. If you’re seeing a blinking icon, the client is counting those keys/clicks.