Not capturing keys in visual studio 2012

Whatpulse 2.0.4 does not capture any keys in Visual Studio 2012. Since i do most of my typing IN Visual Studio this is very frustrating! Please fix…

Here is a screencast showing the issue:


Please check previous threads before making a new thread. There are a few topics discussing these issues and giving work arounds and also state we are working on it.

Then why is it not in the known issues list at the top?

Anyway, i think ii may have found the cause. The issue is that i run visual studio 2012 in administrator mode (required for debugging IIS apps). However Windows probably prevents capturing events across such different security contexts.

If i run vs without admin rights, all works well.

I think this is related as well:

You can’t drag-drop files into a visual studio running as admin.

If this is the case i don’t think anyone but Microsoft can do anything about this, and i don’t think they ever will. I guess i’ll need to stop using IIS to debug my apps.

Because it’s a very uncommon issue, not a lot of apps run as administrator. Running WhatPulse as administrator allows it to get input from the other applications running as admin, do that and it’ll count. The next version will have an option to do it automatically, but it’ll be disabled by default (causes an annoying popup when the client starts up)

Ok. Super. Thanks! That works brilliantly!