No "Open Geek Window" option

There is no “Open Geek Window” option if I search for it or right-click the icon.

I have WhatPulse 3.1 running on my Win10-x64-Laptop, I have WinPcap installed, WhatPulse is NOT running as administrator and I don’t receive any error messages.
WAIT… I have NOT checked the box for WhatPulse running as administrator, but app.log says it DOES… Maybe because I AM accesing my Laptop as an administrator?

I shortened my Log a bit and renamed it to “app.log.txt” so I can upload it here.

It’s called “Toggle Geek Window”, not “Open Geek Window”.

In other words: There is NO option containing “Geek Window”, if I right-click the Icon in the task bar, there are just the options “WhatPulse”, “Pin to task bar”, and “Close window”.
And if I search for “Geek …” in the search bar, there is no result.

That’s not the WhatPulse menu, that’s a Windows menu where you can start the WhatPulse client. After starting it, look at your system tray menu; there will be the client and the menu is there.

Ok, found it, never searched there, thanks.