Lost 12k clicks when exiting and reloading buggy client


I’ve used whatpulse 1.x faithfully for over two years, now. Last week, I finally decided to update to the newest client. I’m starting to regret that decision. Here are the problems that have occurred:

  1. Yesterday, when it automatically pulsed at 7am, it screwed up my total keycount and total clickcount. My keycount went from 9.5 million to approximately 10.5 million, and my clickcount went from 4.6 million to the exact same number (approx. 10.5 million). I tried pulsing and editing the geek window’s layout, and that didn’t fix the problem. Ultimately, “refresh status” in the account information tab of the whatpulse settings window did the trick. However, I’ve noticed that these stats only update periodically. In the old version, I could see my totals update on the fly, as I typed. I’m concerned that I’ll miss my 9,999,999 and 10,000,000 key counts (for a screenshot), which I am quite looking forward to.

  2. Today, whatpulse missed its automatic 7am pulse, and subsequently refused to pulse when I tried manually. I tried everything I could find mentioned on the forum, and nothing worked. No error messages (even after checking that automatic popups were not suppressed); just no response. Eventually, I exited whatpulse and reopened it. After exiting and reopening the client, it pulsed. However, a third problem occurred.

  3. Before I had quit the whatpulse client, I was sitting at approximately 17,500 clicks. After quitting and reloading the client, it stated only 5,500 clicks, so it randomly lost about 12,000 clicks. I checked whether these 12k clicks were already pulsed somehow, and they were not.

Losing keys and clicks is important to me, because I’m a long-time RSI sufferer using whatpulse to track my computer usage so that (1) I can prevent injury to my wrists by stopping after an appropriate amount of usage, and (2) I can track the progress of my affliction over time to see what average level of activity I’ve been able to maintain. I noticed 12k clicks missing this time, but I might not notice in future.

Not sure what you’re referring to here, do you mean the total counts in the ‘Account’ window or have you added the totals to the geek window? If the last, are you using the right variables?

I can’t reproduce this, besides adding the wrong variables to the geek window.

The “Refresh Status” does the same as when pulsing, it requests the totals and ranks from the server. Same stuff. By “periodically” - I assume you’re talking about it that it only updates on pulsing and using the ‘Refresh Status’ button, just like the old client.

What 2.x doesn’t do is add keys/clicks to the totals when you’re typing/clicking. The reason for that is because the totals are out of sync when you pulse from another computer, which confused a lot of people.

Error messages can be hidden at the back of windows if you continue to use the front windows. Automatic pulsing can be disabled by the client if repeated pulses fail for whatever reason (likely reason being no internet), on which you need to pulse manually. If the “Pulse!” button is greyed out, you’re got the option “Work Offline” enabled.

The only way the client will ‘forget’ statistics is when it’s exited through the OS and not the client itself (Icon → Quit WhatPulse). Same as the old client.

I did add the total key and click counts to the geek window, and I am using the correct variables. I explicitly checked the counts in the settings → account tab and the total counts were screwed up there, as well.

I preferred it the old way. I guess you can’t please everyone. It looks like I’ll probably miss those milestones.

I didn’t have “work offline” enabled. The pulse button wasn’t greyed out. There were no windows hidden on my desktop; I already tried minimizing everything and repeatedly pulsing, both by double clicking on the tasktray icon, and by clicking “pulse” in the settings window.

As a matter of fact, I changed nothing. I just exited and restarted whatpulse and it pulsed fine. However, it lost 12k of my clicks.

Clearly, this is incorrect, since I clicked “quit whatpulse” and it terminated normally. It really did lose 12k of my keys and clicks upon normal termination. I suspect the problems are related. Perhaps the issues with pulsing involved an open (local) database transaction, and quitting didn’t commit it.