Linux: WhatPulse not finding keyboard or mouse


I’m new to WhatPulse, I use windows and ubuntu linux, it works fine in windows, but can’t find my keyboard or mouse in ubuntu. I’ve tried multiple times to run the permissions file, but nothing happens and it still doesnt see my keyboard or mouse.
I’m pretty sure I have everything installed that I need to.

Any help is appreciated.


When you say “run the permissions file” - have you gone through the questions it asks and entered the correct answers? “Nothing happens” with that script is not really an option, then it just doesn’t run.

Ah ok! I wasn’t sure what was supposed to happen when I ran it. Nothing happens at all. Nothing opens or ANYthing.

You’re saying that if you run “sh” (or “./”) nothing happens? Something might be seriously wrong with your bash/sh shell then, as the least it should do is echo some lines of texts…

Ok well I gave it another shot and it worked, I got as far as the username, but it didn’t take what I told it. Should I be giving it this username or the name of my computer?

I’m a bit confused as to why it hasn’t been working this whole time but now is.

Thank you for your help btw. I was about to just give up and delete whatpulse

Still can’t figure out what username I need to put in on the permissions prompt.

Any help is appreciated.


It’s talking about adding usernames to local groups on your computer to allow them to read your keyboard/mouse devices, so it’s talking about the local username on your computer.