Keys not counting unless WP window in focus

  1. Which version of WhatPulse are you running? 2.0.4

  2. What is your WhatPulse Username? Jardeath

  3. What Operating System are you using? Windows 7 SP1 64-bit

  4. If you are using version 1.6 or higher, are you logged into an administrator account on Windows so that WhatPulse can access Windows correctly? Yes

  5. What error messages are you receiving (if applicable)? N/A

  6. What programs were you running when the issue happened? None, straight on boot it happens.


When I upgraded to whatpulse 2 things worked fine, then I think on version 2.0.3 this started. Basically keys do not count unless I press them while the whatpulse client window is open and in focus, it needs to be selected. If the window is not selected, keys do not count.

Clicks record perfectly fine. This issue has carried on since I upgraded to 2.0.4, I have tried a few complete uninstalls and reinstalls. I am running the main administrator account, I have opened whatpulse by right clicking it and selecting run as administrator however this does not fix my problem (as it did in the instances of this I was able to google).

Looking for any suggestions, thanks.

What anti-virus software are you running? I wonder if something like that could intercept keys before WhatPulse sees them.

I just Googled and found a couple of other ideas:

  • Do you have any keyboard software installed, eg. from a CD that came with your keyboard?
  • Is WMP.exe/Windows Media Player running in the background?

Have you installed as administrator ? Maybe that can be the issue…

Just guessing…

Even with my antivirus stopped and not running this is still happening.

No other keyboard software.

No windows media player.

It was installed as admin yes, and running as admin.

This happens for me as well, but only with my arrow keys, the rest of the keyboard is fine for me. I’m on 2.0.4 as well.

Same problem, on 2.1.1 now except for the last couple of versions now I don’t get any key counts with the window in focus either.

I’ve got the same issue since updating to 2.1.1.
My keys and clicks are not counting.
They worked fine yesterday when I was working directly on my machine, but I’m in a remote desktop session now to my machine at home, and the keys and clicks are not registering at all.

Sometimes WP doesn’t even respond at all. It doesn’t open the mainwindow on double click (it used to do that), just via rightmouseclick.
As soon as I go to the mouseheatmap, the whole program crashes and stops responding.

[edit]I just reinstalled 2.0.4 as that is a lot more stable than the 2.1.1 version. With 2.1.1 installed and running, eventhough it didn’t register any input, it even prevented my computer from shutting down and rebooting correctly several times. When I unstalled, the issue was solved. 2.0.4 is now correctly registering input again.[/edit]

@Sypheron: WhatPulse will not register any keys inside a remote desktop session, that is by design. Possibly 2.0.4 still did it, but it will not do it again in newer versions. The mouse heat thing may be just because you have too many clicks for it to process within a proper timeframe…that’s why there was a time selector introduced.

As for the original thread, @jardeath: something is blocking the client from getting any input events…this could be an anti-virus, some kind of pragma collector, but I don’t have a list or something…Check what you have running and what they are doing.

For anyone interested I have solved this.

I run Synergy so that my Windows computer can access my Linux one. This seems to only happen when the Linux computer is not up and running, while having the Synergy server running… Kill that and it seems to work fine.

I have the same issue with WP 1.7.1 at work and I also use Synergy.
Will try the new beta there and see if it works better.