Keyboard use doesn't count on mac

I have a MacBookPro early 2011 model running mountian lion and the only keys what pulse records is shift, control, option, and command. Is there a fix for this?

I am having this exact problem – mid 2011 model, not running Mavericks, and I tried to do some forum looking to search to see if anybody else has had this issue, but to no avail.

275+ views and no replies, OP. you are not alone.


For a while, I had been running on the wrong WhatPulse client (every time I tried to Pulse, it would just crash completely with no error message whatsoever, so I hadn’t even bothered to mess with it for a few months) but after updating it to 2.2.1, the only keys it seems to be registering are shift, control, command, etc.

It is literally the middle of NaNoWriMo right now, and practically none of my keys have been logged. :"D I cannot.

I’m not even mad or anything, I’m just trying to figure out what’s going on and/or ride it out until 2.2.2 gets released.


Just a quick one… Have you tried going to System Prefs. → Accessibility → Enable Access for Assistive Devices? I run Mavericks (free from App Store) and WhatPulse logs my keystrokes properly. (The procedure there is different… System Prefs. → Security & Privacy → Privacy → Accessibility and check WhatPulse)

I’ve a similar problem where it does not record certain keys such as the number nine, which is the only one as far, as I’ve seen, that doesn’t work. I have tried what classicmachintosh suggested when the application first updated.

And this is what the 2.3 (or previously 2.2.2) says:

  • OS X: Fix catching keys 9, ~ and caps lock

So it’s not an issue anymore. :wink:

But seems that 2.3 hasn’t released yet?

It’s out there, but not GA correct. Was just letting you know it is a known issue and that it has ben addressed.

Seeing this now with 2.3. Weirdly enough, it was working for me on 2.2.1. Disabled and enabled WhatPulse in Accessibility, no dice

Edit: ok, weird, it’s working for me now. I did restart the app, but I saw that it was still not working after the restart.

Just updated to 2.3.1 and it’s not counting any keys except for Modifers (options, shift, cmd, ctrl, etc).

Had this problem way back with a 2.2 Beta and Mavericks (10.9) but it was cleared up. Seems to be back (at least for me) with WP 2.3.1 and OS 10.9.

I’ve Enabled and Disabled the System Prefs → Security & Privacy → Privacy → Accessibility setting several times and rebooted.

Apple is pretty strict when it comes to the ‘Accessibility’ options. When you upgrade, you need to re-enable the WhatPulse app for it to start working.

So; disable it in the Accessibility tab, save & exit, then enable it again. Not sure if it matters, but it’s best to stop the client before you do so.