"Invalid Token" every single time

I have been using WhatPulse for about a year now, and aside from the occasional Invalid Token problem, I have never had any problems.

I went to pulse this morning after having finished writing a report and I got the “invalid token” message. I was a bit annoyed (I had about 40,000 presses), but let it slide. Then, about 5 minutes later, I accidentally double-clicked the Whatpulse icon (I was trying to access my Spotify icon), and again I got the “invalid token” error.

This being unusual (Seeing as I had barely accumulated 100 clicks in the time since the last error), I tried again, and every single time, I keep getting the “Invalid Token” error, even when I have 0 clicks.

What is happening?

Did you click Reset Token?

Yes, I click “Reset Token” and get the notice that my token was reset. However if I do a few keypresses and clicks and try to pulse just 30 seconds later, it fails again.

I have tried logging out, restarting the client and signing in under another computer profile, and it still doesn’t work…