Heavy lag, and yep its WhatPulse

Well, Ive done some tests, such as uninstalling whatpulse etc and exiting the software and the lag stops, and when I use it again, it simply happens again.

The lag is serious. My mouse pointer literally jumps accross the screen at 1 frame per second, and everything is lagged out.

The keystrokes and mouse completely freeze, and when I press the caps lock key or something on my keyboard, the light doesnt come on for a few seconds.

When WhatPulse isnt running, this does not happen at all.

Any suggestions? I really enjoy using this program, and dont want my 200k keystrokes to have been for nothing, especially when I need to get to the top of my team!

Can you provide system and hardware specifications for me?

Hardware Specs:

8600GT GFX Card
E6550 Duo core Processor

All latest games etc work fine. WhatPulse is the only program on my computer which lags.

XP or Vista?



There are issues with lag that we know of with WhatPulse 1.5 but usually only whilst certain programmes (usually games) are running. Some changes have been made in an attempt to fix this in the next version but it’s quite hard to track down why this is happening.

However in saying all that, I’ve never heard of such major lag problems without anything running - In fact I don’t think it happens this bad with the lag problems we have had reported.

The only way to help diagnose this is to individually close running processes (close process, open WhatPulse, check… if that doesn’t help, close WhatPulse, close another process, open WhatPulse… etc) (instant messengers, audio programmes, whatever) and see if there’s anything WhatPulse might be having a tiff with while it’s running.

You on 32 or 64 bit XP?

I had the same problem on my old computer, the solution for me was to turn off the counting of mouse miles. Maybe that will help you?

Disable mouse miles. This should fix your issue.


Disabling mouse miles completely removed the lag. Thank You.

No problem. I’m still not completely sure what causes the mouse lag when mouse miles is enabled, but it tends to happen frequently on some computer systems. It used to affect me when I used my laptop. Sadly, you have nothing in common with my laptop, which leads me to believe it’s just a case of certain types of mice and how they send signals to the computer.

What type of mouse are you using?


My old system was a AMD XP2000+, 512mb DDR, Radeon 9800pro, MSI motherboard and a Razer diamondback mouse.
When I upgraded the computer I kept the mouse for some time (until it broke) but the mouse mileage worked fine on my new system when playing games, so to my experience it’s not a mouse the problem is hanging on.

I think it’s worth mentioning my own experiences with WhatPulse and lag. I’ve noticed significant mouse and typing lag on two different computers in my house when they ran XP. However, when I upgraded both computers to Vista, the lag completely resolved itself. This seems to suggest that the issue is XP-specific, which is annoying since my ThinkPad still runs XP and is frequently hit by lag from WhatPulse.

Hmm, that’s actually possible. It could be that it’s a bug affecting the runtimes in XP. Anyone elses experiences in this would be greatly appreciated.


i have it whit no progrems runing on vista + latest whatpusle

That’s because this is a 3,5 year old thread… :wink:

I dont think anyones ever bumped one of my topics with a different username before.