[FIXED] WhatPulse 2.6: Mac OSX 10.9.5 Segmentation fault: 11

Running Mac OSX 10.9.5 64-bit.
After upgrading to 2.6 WhatPulse fails to start. When I run


manually I get this output:

4-05-2015 11:38:11.155 INFO “Starting WhatPulse 2.6…”
14-05-2015 11:38:11.163 DEBUG Database file: “/Users/dkniaz/Library/Application Support/WhatPulse/whatpulse.db”
14-05-2015 11:38:11.165 DEBUG Database check: “ok”
14-05-2015 11:38:11.166 DEBUG Opened database in: 3 ms
14-05-2015 11:38:11.170 DEBUG Encrypted file: “/Users/dkniaz/Library/Application Support/WhatPulse/whatpulse.wpw”
Segmentation fault: 11

If I run

rm ~/Library/Application\ Support/whatpulse/whatpulse.wpw
rm ~/Library/Application\ Support/whatpulse/whatpulse.wpw.backup

then it starts, but asks me for credentials and computer name. On a restart everything reoccurs.

What’s the issue here?


Could you run the client with --verbose as parameter? So: “/Applications/WhatPulse.app/Contents/MacOS/whatpulse --verbose” (minus quotes)

If there’s a “get_facebook_login” in the final sentence it’s an issue that’s universal to OSX/Windows/Linux and should be fixed very soon (waiting on confirmation from other people).

Yep that’s the problem:

15-05-2015 21:28:41.788 TRACE Settings::get( “login_via_facebook” )
Segmentation fault: 11

Version 2.6.1 has just been posted to fix this. Use the updater or download from http://whatpulse.org/downloads/