Distance is wrong.

I’ve used other mouse distance counters, they all have options to set your screen resolution and size.

I know for sure my cursor didn’t travel 1 mile in 1 hour, that’s just too much, it must think that I’m using a MUCH SMALLER screen resolution.

Any way to change this? Or should I just disable the mouse distance counter?

What is a ‘much smaller’ resolution? I develop on 1900xSomething, which is pretty small.

Could you also link to those other apps?

Seems to have resolved its self after re-boot.