Distance counter flawed

I know the distance counter is mostly novelty, but it seems like there’s something wrong with the way it measures distance.

I set my distance type to meters and open the geek window so I can see how much distance WP is counting. If I move the cursor very slowly from one side of the screen to the other, the distance it counts is reasonably accurate. However, if I flick the cursor from one side of the screen to the other as fast as possible, only about 1/3 as much distance is counted. Surely the distance should be the same? I could understand if I was just flicking it back and forth and WP didn’t always sample the cursor while it was on the other side, but I’m not doing that. I’m pausing, moving the cursor across once and waiting to see how much distance is added.

This isn’t a new issue. I was able to reproduce it with the last 1.6.x version. I’m using Windows XP at home and at work. I remember checking the accuracy of the distance counter before and thinking it seemed ok. Was there a change to how distance is measured since v1.5?

You’re completely right about it not counting quite so accurately, and it was changed in both 1.6 and again in 1.7. But there’s going to be a new way of counting it again in the next version so it’s just a matter of trial and error until it’s finally deemed an accurate statistic.

I can say it doesn’t have the problem on a Mac, if you ever wanted to upgrade to a decent computing experience :wink: - But yeah, next version will be around soon so hopefully there’ll be some changes for the better.