[CLOSED] WhatPulse not starting - Ubuntu 12.04 on Chromebook


I’ve installed Ubuntu 12.04 on my Chromebook via Crouton and I’ve been trying to get Whatpulse installed on it for several days now.
I’ve installed all the packages on the help page, and many other QT packages in an attempt to get it to work, but it won’t even start.

It’s set to execute and everything.

I’m not sure what the issue is, unless it has to do with the fact that the Ubuntu install is on a Chromebook.

Any help would be appreciated!


What is the error the client gives? Run it via commandline to see. If it’s a Segmentation error and you’re using 2.6, update to 2.6.1.

It gives no error at all. It doesn’t even start up when I click the executable. It also does nothing when I try to run it from terminal with ./whatpulse

But now that 2.6.1 is out I’ll download that and try it.

Does nothing is not really an option…running it from terminal should always give some message, whether from the client or from the os. I suggest capturing the terminal session when you’re running it and see what it says.

You’re completely right. I think the fact I was using an installed terminal rather than the one that came with the install on the chromebook was doing something weird.

When I type


in the terminal I get

bash: ./whatpulse: cannot execute binary file

But when I double click the binary file, nothing still happens.

EDIT: Tried installing the new version 2.6.1 and still get the same things happening

Well there you go, WhatPulse is simply not compatible with a Chromebook. Probably because it has a different processor architecture.

I didn’t realize that’s what it meant. I’ve been scouring the internet looking for packages that could give that error or packages related to whatpulse.

This chromebook does have a different processor achitecture, its ARM.

Thanks for the help.