Client crash on launch (v2.7.1)


My client crash on launch without any error message

This is what WP look in the taskbar when i launch him :

Windows Anniversary (The one who broke CMD for CLI color syntax) x64
Intel(R) Core™ i5-4670K CPU @ 3.40GHz

Only Nvidia & Logitech service was running during try

What i actually tried :

  • Remove whatpulse completely (also remaining key … etc Sad )
  • Remove WinPcap
  • Ccleaner → clean register
  • Open regedit → remove everything with search “whatpulse”
  • Reboot
  • Delete whatpulse.db & whatpulse.wpw & the complete folder
  • Disable my antivirus
  • Disable my firewall
  • Install a old version (2.6.3)
  • launch in admin mode
  • Compatibility mode
  • Install the 2.6.3 and update with your updater.exe without launching WP
  • Disable my network protection
  • Use my phone connection

Some note :

  • I own and manage my own network
  • I didn’t install nothing from past 3 month execpt CCleaner to try to repair this issue
  • Still work on my laptop with the same update
  • WinPcap is not install i don’t use network stats

I’m really out of ideas why this happen, any help is welcome



Does it actually crash, or does it look like the screenshot you posted? If so, that just means it’s not logged in and not counting. Click the icon to login.

Hi smitmartjin,

i have recorded what happen when my PC launch

The main screen popup for like 3sec, the W icon on the taskbar with red alert (the screen i linked on the main post) stay for 5 more second and all vanish without any error message

EDIT : When i launch Wp after the boot, the exact same thing happen

Can you make the video public?

My bad, done

Still on my way try to fix this issue and now the app.log write some stuff

23-10-2016 16:21:52.322 INFO “Starting WhatPulse 2.7.1…”
23-10-2016 16:21:52.372 DEBUG Installed CrashRpt!
23-10-2016 16:21:52.376 DEBUG Database file: “C:/Users/Sovex/AppData/Local/WhatPulse/whatpulse.db”
23-10-2016 16:21:52.377 DEBUG Database check: “ok”
23-10-2016 16:21:52.379 DEBUG Opened database in: 4 ms
23-10-2016 16:21:52.385 DEBUG Running WhatPulse as Administrator! :slight_smile:
23-10-2016 16:21:52.385 DEBUG Encrypted file: “C:/Users/Sovex/AppData/Local/WhatPulse/whatpulse.wpw”
23-10-2016 16:21:52.385 DEBUG Unable to open savefile
23-10-2016 16:21:52.386 WARN Failed to load ’ “C:/Users/Sovex/AppData/Local/WhatPulse/whatpulse.wpw” ’ - trying backup file
23-10-2016 16:21:52.386 DEBUG Unable to open savefile
23-10-2016 16:21:53.041 DEBUG Loaded application aliases
23-10-2016 16:21:53.268 WARN libcap not available:
23-10-2016 16:21:53.268 DEBUG Detected that WinPcap is not available and falling back to Windows APIs! No unpulsed online data this way! :frowning:
23-10-2016 16:21:53.344 WARN Failed to resolve symbol SHGetSpecialFolderPathW
23-10-2016 16:21:53.377 DEBUG WhatPulse 2.7.1 has started
23-10-2016 16:21:55.832 DEBUG Starting timers and collector…
23-10-2016 16:21:55.837 DEBUG Started watchdog.
23-10-2016 16:21:55.838 DEBUG enableInputHook: true
23-10-2016 16:21:55.839 DEBUG LowLevelHookHandler starting
23-10-2016 16:21:55.839 DEBUG Enabling lowlevel input hooks
23-10-2016 16:21:55.847 DEBUG Network ports description file ( “C:/Users/Sovex/AppData/Local/WhatPulse/network-ports.csv” ) does not exist! The client will not be able to translate port numbers to human readable form.
23-10-2016 16:21:56.398 WARN Unable to resolve GetModuleFileNameExW

You previously said that you disabled your antivirus, it that still the case in the video? If the log you posted is the only thing it logs, there’s no reason why it would crash, so I’m thinking once the keyhooks install (± 10 seconds after launch) - something thinks the client is being malicious and shuts it down.

Also, why are you installing an old client? (2.6.3 and not 2.7.1?)

On the video my antivirus was ON, but everything disabled the error is the same, and the log remain the same

I’m not installing a old client, but that one of my multiple attempt to fix this issue

Well, something seems to be killing it - pretty much everything the client can do to crash itself will be logged in the app.log, which has nothing, according to the information you’ve provided so far.

Exit all background applications and try each time to see which one is the culprit.

I almost kill everything i can and this still don’t work

I added exepction to my antivirus, even uninstall and WP still crash on the same exact line

23-10-2016 16:21:56.398 WARN Unable to resolve GetModuleFileNameExW

On Google some speak about game corrupt the kernel32.dll on Sys32
I play alot of game, this could be true ? Like GetModuleFileNameExW seem a class WP use to work

Hrm, not getting far with canceling out other apps?

GetModuleFileNameExW is a Windows function that the client uses to get information from Windows about running applications. It is completely safe and the client handles it gracefully when it can’t get any info from Windows due to whatever reason.

But, if your Windows install itself is corrupt, it might take the client down…but to be honest I have not seen behaviour with WhatPulse like that. You might want to run a Windows repair and see what that does.

I have tried that :

sfc /scannow and DISM /Online /Cleanup-Image /RestoreHealth

This is what run on my computer when it’s start

My problem started early october, that my program list (I installed CCleaner for the other thread who had similar crash at launch)

If you see anything can cause trouble, i’m a bid out of idea
You told me about webhook, i have change my DNS, my IP but still not working :frowning:

I just tried to launch Windows in safe mode with networking (so there ANY other program running) and it’s still crash on the exact same line

  • other WP client work on the same network

  • it’s allowed in and out in the firewall

Same problem… can’t seem to find a solution.