Cant install the linux client

Hello,

I get the following error:

atouba@Ideapad:~/Programme$ ./whatpulse32 QSqlDatabase: QSQLITE driver not loaded QSqlDatabase: available drivers: QMYSQL3 QMYSQL Failed to open the database: QSqlError(-1, "Driver not loaded", "Driver not loaded")

I tried to get all the needed libraries via apt-get, but the most cant be found. Maybe not the right sources? But which do I need to get all the libaries?

Any Ideas?

Are you sure you got the libqt-sql-sqlite package installed? Looks like that is the only problem.

I found that libqt-sql-sqlite solved that problem.

However, I use Debian testing (fully updated) and have the following issue:

/lib/libc.so.6: version `GLIBC_2.14’ not found (required by ./whatpulse)

Debian is currently not supported because of the outdated packages it uses. It’s on the roadmap to remove or recode some features to work with an older version of Qt.

There is someone that got it running after updating a lot (http://whatpulse.org/forums/showthread.php?tid=1982 ) - but I wouldn’t recommend trying it if you don’t want some heavy troubleshooting.

Okay thanks. Is there a way I can get a copy of the last version of Whatpulse (1.xx) that used to be the main download?

Thanks!
I installed the libqt-sql-sqlite package. But now I got this error:

atouba@Ideapad:~/Programme$ ./whatpulse Database check: "ok" "/home/atouba/.local/share/data//WhatPulse/whatpulse.db" ./whatpulse: symbol lookup error: ./whatpulse: undefined symbol: _ZN9QListData11detach_growEPii

What OS are you on?

That’s still on jmrk.whatpulse.org

Ubuntu 10.04 (EasyPeasy 1.6)

That’s probably too old to work properly. I’ve not tested below version 11.

You should upgrade either way, but try to go to 11 at least, if not the latest.

Hm okay. Maybe a fresh new install with the current Ubuntu is the best. I wanted to wait for a new EasyPeasy Release but maybe that will never happen. :smiley: Thanks.

Just got Whatpulse x64 working on an Ubuntu Server 12.04 with Gnome-desktop. That was actually a breeze to install.

Still highly unsure how to NOT install the desktop to run Whatpulse.

Anyone got the network stats working?

Will have a go at network stats later :slight_smile:

I’ve just gotten the networking to work.

@smijtmartin - maybe you could setup a knowledgebase article for every distro + version - as far as there is valid information. – and since I can’t post in my old thread in the beta: the network problem (with wired ethernet) persists in linuxmint14 even with the non-beta. However, I’m switching to ubuntu (with cinnamon desktop) anyhow…

So here’s what I did:

  • Freshly installed ubuntu 12.10 64bit (only my /home partition remained)
  • installed the following packages (some of them might already be installed!):
apt-get install libqt4-core
apt-get install libqtwebkit4
apt-get install libssl-dev
apt-get install libpcap0.8
apt-get install libpcap0.8-dev  # the dev one was actually the one that made the "libpcap not available" - message go away....
  • ran this command:
sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse
  • downloaded and executed the permission-script from http://jmrk.whatpulse.org/ to get key and mouse/touchpad capturing running
  • did the xorg-script for my laptop’s touchpad on the same page.

and here I am, glad to have a working whatpulse setup on my work notebook…

Thank you for your explanation! I have it working now! :smiley:

I added your transitional package, but it remains the same.

http://whatpulse.org/forums/showthread.php?tid=2036

I updated to Lubuntu 12.10 and my WhatPulse works not, but its not tracking die Network stats. I done all your steps (without your last two, my touchpad counts already)… All packages are installed… any ideas? Afer the "sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse
" there was no response, no error code… So i think, it was right?
My whatpulse file is on my desktop (“Arbeitsfläche”, Workplace(?)).

And one other “problem”: WhatPulse is only starting as root (gksudo). Any idea how I can start WP at System Start?

Sorry for my broken english :X

edit:
I never had a “libpcap not available” - message

I’m having issues with the network stats as well.
Running a fresh Ubuntu 12.10 x64 installation on my desktop. Used the instruction above. Everything works fine except counting the network stats.

Had no output regarding the following command, but I think thats OK:
sudo setcap cap_net_raw,cap_net_admin=eip ./whatpulse

I’ve tried running whatpulse as root, but that didn’t work either.
Any suggestions?

To both of you: did you try running the client from command line? If not, please do so and paste the output - I might see something - but please bear in mind, I’m not official support! :wink:
The “libpcap not available”-message was output to console. Not a window.
And yes, setcap doesn’t output anything if it works…