Can't edit dynamic image properly

Hi, I’ve tried editing my dynamic image into something else recently, but the editor is broken for me.
I’ve tried in both Google Chrome and Internet Explorer, basically at the stage where you pick the text for the dynamic image, you can pick a text and its color and whatnot, but you can’t see the changes (color changes) until you click “Save Image”. Also if you click “Save Image”, when you refresh the editor page, you’ll see 2 of the text you picked for each statistic, you can’t move the text in the image at all, and if you try to delete the text duplicates, it acts as if there was no duplicate at all and you deleted the original or something.

It’s weird and I can’t work with it, not sure if it’s just me.

For some reason you had double of everything stored, which confused the editor. I wiped it clean so you can add new text.

I got it to work this time, thanks!

Think I’ve figured out what caused the bug, duplicating the text things. Switching the font to Arial then saving causes it to bug out the next time you try to edit it.